PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-27770

Document can be dragged and dropped between folders by a user with View-Only permission

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.1.10 EE GA1
    • Fix Version/s: 6.2.0 CE M4
    • Environment:
      Liferay Version: 6.1.10 EE GA1
      OPERATING SYSTEM: Linux
      APPLICATION SERVER: Tomcat 7.0.x
      JAVA VIRTUAL MACHINE: Java 6
      DATABASE: MySQL 5.0
    • Similar Issues:
      Show 5 results 

      Description

      To recreate the issue
      1) Add a document library portlet to a page
      2) create a folder in the home page of the document library
      3) upload documents to the document and media portlet
      4) Create a user with only view permission to the document library and login as that user
      5) Navigate to the document library and drag and drop the document to the folder

      The document is not actually moved. The message that: Your request completed "Successfully" , is wrong. It should be explicit that that the user cannot move the document.This happens only in List View of document and folders

        Activity

        Gaurav Jain added a comment -

        Being part of community verifier program, I tried reproducing this issue against Liferay 6.2.0 CE M4 tomcat bundle/MySql 5.5.17.

        But Can't reproduce issue.
        It has likely been solved in a recent release and I recommend this can be closed.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 21 weeks, 6 days ago

              Development

                Structure Helper Panel