Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-27816

Organizations - "Do not have the required permissions" error message after a user updates an organization

    Details

    • Type: Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.0 CE GA1, 6.1.10 EE GA1, 6.2.0 CE M2
    • Labels:
    • Environment:

      Description

      If a user has permissions and updates an organization, the user will get a "You do not have the required permissions" error message after clicking Save. However, the changes do save.

      1. Create a User: Test
      2. Update Test's password
      3. Create an Organization: Orgtest
      4. Assign the Organization to the User
      5. Create an Organization Role: Orgrole
      6. Assign Orgrole to Test
      7. Navigate to Control Panel > Roles and click on Actions > Define Permissions for Orgrole
      8. Select Organization Administration in the Add Permissions dropbox and check the following permission under Organization:
        • Manage Users
        • Update
        • View
      9. Click Save
      10. Sign Out and Sign In as user: Test
      11. Navigate to the Control Panel > Users and Organizations and click on Actions > Edit for Orgtest
      12. Update the name to Orgtest2 and click Save
      13. You will get a "You do not have the required permissions" error
      14. Click on Users and Organization, Orgtest has been updated to Orgtest2

      Expected: There should not be an error message displayed when the user as Update and View permissions for Organizations
      Actual: User gets an error message

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              albert.lee Albert Lee
              Reporter:
              albert.lee Albert Lee
              Participants of an Issue:
              Recent user:
              Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                9 years, 2 weeks, 5 days ago

                  Packages

                  Version Package
                  6.1.1 CE GA2
                  6.1.20 EE GA2
                  --Sprint 11/12
                  6.2.0 CE M2