Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-28336

Membership assignment won't work if a user doesn't have any organization.

    Details

      Description

      Steps to reproduce:

      1) Created user "u1" and "u2" and "manager"
      2) Assigned "u2" to any organization
      3) Created a Role called "Manager" for this "manager" user with the following permissions:
      Control Panel->User Groups->Access in Control Panel
      Control Panel->User Groups->View
      Trunk and 6.1.x :
      Portal->Users and Organizations->User Group->View
      4) Added permission per resource to role "Manager"
      ugroup - Assign Members
      ugroup - View
      5) Created a UserGroup called "ugroup"
      6) Impersonated "manager"
      Result: If "manager" goes to Control Panel->User Groups and selects "Assign Members" only the "u2" user are displayed.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              pani.gui Pani Gui (Inactive)
              Reporter:
              tamas.molnar Tamas Molnar
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                9 years, 2 weeks, 2 days ago

                  Packages

                  Version Package
                  6.0.X EE
                  6.1.1 CE GA2
                  6.1.20 EE GA2
                  --Sprint 11/12
                  6.2.0 CE M2