PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-2881

Access to a restricted community virtualhost is not handled properly

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 5.1.2, 5.2.2
    • Fix Version/s: 5.2.3
    • Component/s: None
    • Labels:
      None
    • Environment:
      All
    • Branch Version/s:
      5.1.x
    • Backported to Branch:
      Committed
    • Similar Issues:
      Show 4 results 

      Description

      When a user who does not have appropriate access attempts to login to a restricted community through a virtualhost, the system apparently goes into an infinite loop and the browser displays a cannot reach destination error. Here are the steps to reproduce this:

      1. Log in as an Admin.
      2. Create a user.
      3. Create a restricted community.
      4. Add a private page to the community, and no public pages.
      5. On that page, change the private virtualhost to test.mypage.com
      6. On your host file, point test.mypage.com to the local IP address (in order simulate DNS entry)
      7. In your browser go to http://test.mypage.com:8080/
      8. Attempt to log in as your created user.

      I was able to reproduce this in 5.1.x. Running on trunk, I was only able to make it to step 7; I never had the opportunity to attempt a log in. The error however, was the same.

        Issue Links

          Activity

          Douglas Wong added a comment -

          A fix for 5.1.5 has been created. For trunk, use LPS-342 for using the same functionality.


            People

            • Assignee:
              Douglas Wong
              Reporter:
              Douglas Wong
              Recent user:
              Randy Zhu
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                5 years, 46 weeks, 1 day ago

                Development

                  Structure Helper Panel