PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-28886

File added to the WebDAV folder will display as a locked draft and cannot be downloaded

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.1 CE GA2, 6.1.20 EE GA2
    • Fix Version/s: 6.2.0 CE M2
    • Labels:
    • Environment:
      Tomcat 7.0 + MySQL 5. Portal 6.1.20 GIT ID: 435890a8949663b4ba8010ee61af8ac9893d7591.
    • Fix Priority:
      5
    • Caused by:
      Other bug fix
    • Where was the bug?:
      Java
    • Similar Issues:
      Show 4 results 

      Description

      Once the User adds a document file into the WebDAV folder, the system will display the document as a locked draft in the Liferay Instance. The User will also be unable to download the document.

      Steps to Reproduce:

      1) Add Documents and Media portlet
      2) Add Folder1
      3) Add Multiple Documents into Folder1
      4) Click the Arrow icon in the drop down of Folder1 on the vertical menu
      5) Select 'Access from Desktop'
      6) Copy the WebDAV URL
      7) Connect to the Map Network Drive with the WebDAV URL
      8) Copy and Paste a Document file into the WebDAV folder
      9) Navigate back to the Liferay Instance
      10) Assert that the newly added document file displays in Folder1
      11) FAIL - Document displays as a locked draft in the Documents and Media portlet

      12) Select the locked draft
      13) System displays 'You now have a lock on this document. No one else can edit this document until you unlock it. This lock will automatically expire in 1 day.'
      14) Version File will display as PWC
      15) Click Download
      16) FAIL - System displays the error: Not Found

      1. webdav1.jpg
        71 kB
      2. webdav2.jpg
        102 kB
      3. webdav3.jpg
        40 kB

        Issue Links

          Activity

          Irene Weber added a comment -

          Can reproduce on 6.1.1 GA2 and Windows7.

          Edward Shin added a comment -

          I can also produce on 6.1 GA2 and OSX Lion

          Mika Koivisto added a comment -

          Please see comments in pull request.

          Michael Saechang added a comment -

          Committed on:
          Portal 6.2.x GIT ID: c5991df96ad06557be6b9e0b5f19b7b585d4958d.

          Mark Jin added a comment - - edited

          PASSED Manual Testing following the steps in the description.

          Reproduced on:
          Tomcat 7.0 + MySQL 5. Portal 6.1.20 EE GA2.

          FAIL - Document displays as a locked draft in the Documents and Media portlet.
          FAIL - System displays the error: Not Found。

          Fixed on:
          Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 0304c1dd8252f0d9db59969dba1a1bd4c12ea702.

          The document shows correctly.
          Able to download document file.


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 26 weeks, 5 days ago

                Development

                  Structure Helper Panel