PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-29421

Liferay version number for 6.1.20 EE causing market place portlets to show as incompatible.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 6.1.20 EE GA2
    • Fix Version/s: 6.1.20 EE GA2
    • Component/s: WCM
    • Labels:
      None
    • Environment:
      Oracle Enterprise Linux 6.2, JDK 6 Update 33
    • Similar Issues:
      Show 3 results 

      Description

      There was a problem with the liferay-plugin-package.xml for the main portal which caused issues with the Liferay Market Place showing all portlets as not being compatible. Basically, the 6.1.20 version number has not been included in the GA2 EE build correctly in ROOT/WEB-INF/liferay-plugin-package.xml.

        Activity

        Mika Koivisto added a comment -

        Ryan can you check this issue?

        Ryan Park added a comment -

        I'm not sure I understand, Marketplace does support Liferay Portal EE 6.1 GA2. Are you talking about the new SP1?

        Graeme Steyn added a comment -

        Apologies for the late response - been on leave. I have just attempted to reproduce the problem using the 6.1 EE GA2 bundle (liferay-portal-tomcat-6.1.20-ee-ga2-20120731110418084) and MySQL 5.5.20 without success. It appears that this must have been fixed on the Liferay Market place server side. When the problem was originally logged, the 6.1 EE GA2 distribution contained the following in ROOT/WEB-INF/liferay-plugin-package.xml:

        <?xml version="1.0"?>
        <!DOCTYPE plugin-package PUBLIC "-//Liferay//DTD Plugin Package 6.1.0//EN" "http://www.liferay.com/dtd/liferay-plugin-package_6_1_0.dtd">
        
        <plugin-package>
        	<name>Liferay Core Plugins</name>
        	<module-id>liferay/core-plugins/6.1.0/war</module-id>
        
        :
        :
        	<liferay-versions>
        		<liferay-version>6.1.0</liferay-version>
        	</liferay-versions>
        </plugin-package>
        

        When doing initial testing of our system this needed changing to

        <?xml version="1.0"?>
        <!DOCTYPE plugin-package PUBLIC "-//Liferay//DTD Plugin Package 6.1.0//EN" "http://www.liferay.com/dtd/liferay-plugin-package_6_1_0.dtd">
        
        <plugin-package>
        	<name>Liferay Core Plugins</name>
        	<module-id>liferay/core-plugins/6.1.20/war</module-id>
        :
        :
        	<liferay-versions>
        		<liferay-version>6.1.20</liferay-version>
        	</liferay-versions>
        </plugin-package>
        

        Without this change, the market place would show ALL portlets (EE included) as not being compatible with this version - the same "Not Compatible" message that you currently get for CE portlets when running EE.

        Ryan Park added a comment -

        I'm glad it's resolved but I'm still not sure I understand the problem

        It sounds like you were trying to access the Marketplace with an older Liferay 6.1.0 build. If this is the case, then there are no compatible apps in the Marketplace since all apps in the store are for Liferay 6.1.1 or better.

        However, if the problem comes back please reopen this ticket and I can revisit the issue.

        Thanks!


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 15 weeks, 5 days ago

              Development

                Structure Helper Panel