PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-29765

The Control Panel Server admin portlets don't work after start-up because the admin/view.jsp is being overriden

    Details

    • Similar Issues:
      Show 5 results 

      Description

      I have a multi-site instance. I wanted to disable User pages for all sites. I found the following property settings on the forums and applied them to portal-ext.properties:

      #

      1. Disabling user private and public pages
        #

      layout.user.private.layouts.enabled=false
      layout.user.private.layouts.modifiable=false
      layout.user.private.layouts.auto.create=false

      layout.user.public.layouts.enabled=false
      layout.user.public.layouts.modifiable=false
      layout.user.public.layouts.auto.create=false

      After restarting, the User pages were disabled as expected, but the admin/view.jsp file was overridden with the attached version of the file. I tried reverting the changes to the portal-ext.properties to no effect. I resorted to replacing the overridden view.jsp with the correct one after start-up.

      Further investigation identified that the overwriting happens as soon as the database comes up during the start-up routine.

      Although I failed to reproduce this problem on a clone of the environment made before this issue manifested itself, I'm hoping for some guidance on where this database trigger might be found so I can fix the problem as opposed to re-installing.

        Activity

        Hide
        Gaurav Jain added a comment - - edited

        Louis Richer, Thank you for your report.
        Have you had the opportunity to discuss this issue on the community forums?
        If so, were there other users who were also experiencing this problem?

        Thanks!
        Since this is not a bug. I recommend this issue can be closed

        Show
        Gaurav Jain added a comment - - edited Louis Richer, Thank you for your report. Have you had the opportunity to discuss this issue on the community forums? If so, were there other users who were also experiencing this problem? Thanks! Since this is not a bug. I recommend this issue can be closed
        Hide
        Christophe Cariou added a comment -

        I found a reproductible case and the origin of the bug :
        The Private Plugin installer Hook (found on market place) is replacing admin/view.jsp by a reduced one (the same as in the attachment).

        So the bug come from this plugin.

        Th workaround is to restore a correct view.jsp from an original bunlde (and eradicate this view.jsp from the plugin)

        Show
        Christophe Cariou added a comment - I found a reproductible case and the origin of the bug : The Private Plugin installer Hook (found on market place) is replacing admin/view.jsp by a reduced one (the same as in the attachment). So the bug come from this plugin. Th workaround is to restore a correct view.jsp from an original bunlde (and eradicate this view.jsp from the plugin)

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 46 weeks, 4 days ago

              Development

                Structure Helper Panel