It was confusing to have kaleo-web customize com.liferay.portal.service.impl.CompanyLocalServiceImpl with com.liferay.portal.workflow.kaleo.hook.service.impl.CompanyLocalServiceImpl
Some people didn't realize that they were 2 different classes with the same name, but different packages.
Renamed the hook service impl to: com.liferay.portal.workflow.kaleo.hook.service.impl.KaleoCompanyLocalServiceImpl
We'll always prefix the customized class with a prefix now so that developers don't get confused.
This is just a coding convention.