PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-30342

Facebook authentication does not work after upgrade from 6.0.6 CE to 6.1.1 CE

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.1.1 CE GA2
    • Fix Version/s: 7.0.0 M2
    • Labels:
      None
    • Environment:
      Ubuntu Linux 12.04.1, MySQL 5.5.24, Tomcat 7.0.27 (bundled with Liferay).
    • Similar Issues:
      Show 5 results 

      Description

      After successful upgrade from 6.0.6 CE to 6.1.1 CE (without any error messages in the logs), Facebook authentication just stopped working (but it worked perfectly right before the upgrade on 6.0.6 CE).

      When user clicks the "Facebook" link within login portlet, the popup window opens, Facebook login appears, after successful Facebook login and authorization popup windows closes, and browser (re-)loads portal page, but the user sees the same login screen, i.e. the user is not logged in still.

      I attached the part of the access log starting with click on "Facebook" link and ending with loading of the same login screen. Other logs are not updated during this process, i.e. no exceptions or any warnings are logged.

      I've tried to play with authentication settings:

      • checking/unchecking "Require strangers to verify their email address?" on General tab
      • checking/unchecking "Verified Account Required" on Facebook tab
        Nothing helps.

      Please, help me to find the solution or workaround. This is not critical, of course, but it's a major loss of functionality, especially taking into account that a number of registered users of our portal used Facebook authentication to create their accounts and are using it log in.

        Activity

        Nnanna Madu added a comment -

        Hey Albert.. I'm having the same issue. Please have you been able to find a solution (or a workaround or reference)? This issue has been a thorn in my flesh this week

        Albert R. Timashev added a comment -

        Hi Nnanna! No, I have not found any solutions to this problem. I just had to turn off Facebook login at my websites until the problem is solved by Liferay team. However I have not upgraded to 6.1.2 GA3 yet. Can you confirm that 6.1.2 GA3 is still affected by this bug?

        Ryan Arbolado added a comment -

        Hi Albert,

        I am experiencing same issue under Linux environment only. It's totally working under Windows. Is your system behind the proxy as well? I'm still looking for the root cause. Thanks!

        Albert R. Timashev added a comment -

        Hi Ryan,
        I have not tested it on Windows since I develop on Mac and have a production site on Linux. There are no any proxy in both my development and production environment, so if you suspect your proxy is causing this issue, then most likely it's not (at least it's not the only cause. I'm still looking for solution too :\

        Ryan Arbolado added a comment -

        My bad, we have cleared the auto login hooks configuration while doing the optimization in our development server. That's why it is redirecting to homepage again. It is working for my case now after adding the Facebook auto login configuration.

        Albert R. Timashev added a comment -

        Hi Ryan,
        Can you give me more details on exactly what did you cleared and now restored, so I may check the configuration on my side?

        Ryan Arbolado added a comment -

        Look for this property "auto.login.hooks", add the FacebookAutoLogin class. By default, it should be there.

        Tomas Polesovsky added a comment -

        Hello,

        let me know if the issue still persist, I wasn't able to reproduce it.


          People

          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              20 weeks, 2 days ago

              Development

                Structure Helper Panel