PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-30483

If the user creates a document type on a different default local (e.g French or Spanish), the user is unable to publish to remote live

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.1 CE GA2, 6.1.20 EE GA2
    • Labels:
    • Environment:
      Tomcat 7.0 + MySQL 5. Portal 6.1.x EE GIT ID: 58c22bcf801ec7044f7181cf899c82a7c885c852.
      Tomcat 7 + MySQL 5. Portal 6.2.x GIT ID: 5da68f28506d82faa7c71d7418e5b992b1a2fd25.
    • Branch Version/s:
      6.1.x
    • Backported to Branch:
      Committed
    • Fix Priority:
      4
    • Similar Issues:
      Show 3 results 

      Description

      1. Set up a remote live environment.
      2. Start Liferay on the staged environment.
      3. In the Control Panel, change the Portal Settings to a different locale. I used fr_FR for my test.
      4. In documents and media, create a new document type (e.g. name = Test with the date and text fields)
      5. Upload a document with that Document Type.
      6. Publish this to remote live. The portlet becomes unavailable with the attached stack trace. (See attached)

        Activity

        Michael Saechang added a comment -

        Committed on:
        Portal 6.2.x GIT ID: 8185b219d91aa75ac94e6193bffd025a512648a1.

        Mark Jin added a comment -

        PASSED Manual Testing following the steps in the description.

        Reproduced on:
        Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: a46deb5f39017e00aaf800129ba5f999361cd9c5.

        The portlet becomes unavailable with the attached stack trace.

        Fixed on:
        Tomcat 7.0 + MySQL 5. Portal 6.1.x EE GIT ID: 1f82748a33f2a456bb0f125deaae381c8d12bc4b.
        Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 9b255d10809de5409f17b494dc9b54d96415d181.

        Publish to remote works well. Able to see the document and document type.

        Michael Saechang added a comment -

        Thank you Mark for testing. Closing as 'Fixed'.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 26 weeks, 3 days ago

              Development

                Structure Helper Panel