PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-31190

GRP-Calendar - Event spanning multiple months does not show correctly and crashes

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.2.0 CE M2, 6.2.0 CE M3
    • Fix Version/s: 6.2.0 CE M5
    • Component/s: Calendar, Collaboration
    • Labels:
    • Environment:
      Tomcat 7.0.27 + MySQL 5. liferay 6.2.0 CE M2 - liferay 6.2.x - jdk 6
    • Fix Priority:
      3
    • Similar Issues:
      Show 5 results 

      Description

      When adding a long event that spans from month to next month
      eg. selecting start date 28 nov 2012 and end date 22 dec 2012
      the calendar freezes. (screenshot1)
      After a refresh the portlet revives.
      Starting month does not show selected event dates (screenshot2) but next month does. (screenshot3)

      When adding multiple months events eg. 28 nov 2012 to 22 Jan 2012 (screenshot4) calendar crashes with "portlet temporarily not available" pink message (screenshot5) and event not saved nor shown.
      Attached log.

      1. calendar-error.log
        37 kB
        Davide Rossi
      1. Screenshot1.png
        16 kB
      2. Screenshot2.png
        3 kB
      3. Screenshot3.png
        25 kB
      4. Screenshot4.png
        18 kB
      5. Screenshot5.png
        19 kB

        Activity

        Adam Brandizzi added a comment -

        The bug was not reproducible at the most recent versions of Liferay codebase. If one gets to reproduce it again, please reopen the bug with instructions.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 14 weeks, 2 days ago

              Development

                Structure Helper Panel