PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-31471

BlogsEntryTestUtil should not use the service to add the initial blog entry to avoid using the workflow

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.2.0 CE M3
    • Fix Version/s: 6.2.0 CE M3
    • Component/s: Dev Tools, Testing
    • Labels:
      None
    • Fix Priority:
      2
    • Similar Issues:
      Show 5 results 

      Description

      BlogsEntryTestUtil is currently creating the initial blog entry the tests are working on by calling BLogsEntryLocalService. This results in calling the workflow and because of that the initial blog entry will always be in an approved state, which is not intended. In fact all test expect the entry to be in a draft state and the activity records clean.

      The fix would be to manually create an instance of BlogEntryImpl and store it via the updateBlogEntry() method.

        Activity

        Miguel Pastor added a comment -

        Manu,

        Esta tampoco está en master

        Manuel de la Peña added a comment -

        Closing as BlogsTestUtil is creating blog entries depending an status: approved or not.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 15 weeks ago

              Development

                Structure Helper Panel