PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-31570

Enterprise Calendar - Dropdown Menu when editing details of an event is cut off

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE M3
    • Fix Version/s: 6.2.0 CE M2, 6.2.0 CE M3
    • Component/s: Calendar, Collaboration
    • Labels:
    • Environment:
      Tomcat 7 + MySQL 5. Portal 6.2.x GIT ID: 9741331a07b220cba5079904f59267700dd06550.
      Plugins 6.2.x GIT ID: 455ad45725b357b7e30823d263ec0bfb2a93dc60.
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      When editing an event's details in the Edit Details popup window, the default size of the window cuts off the drop down menu selections in that window. The user has to manually resize the Edit Details window in order to display the drop down menu selections completely.

      1. Add an event to a calendar
      2. Invite a test user to event
      3. Sign in as test user and reply as Maybe to event
      4. Sign in as admin user and click Edit Details for event
      5. Click dropdown next to test user
      6. Dropdown box's default options are cut off as seen in attached screenshot
      1. dropdown menu.PNG
        50 kB
      2. screenshot2.PNG
        2 kB
      3. screenshot3.PNG
        6 kB

        Issue Links

          Activity

          Sharon Choi added a comment -

          FAILED Manual Testing following the steps in the description.

          Failed on:
          Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: a4076e2b170d4b627bea9a95399cb0f955501c57.
          Plugins 6.2.x GIT ID: 6afa94b9c21a8f46bd8a955bd43afe6b8b93bf4b.

          Following the steps in the description, and with the window completely maximized, the Edit Details i-frame will not automatically resize to the dropdown menu. The user will still see that all the dropdown menus on the far right will still be cut off, unless user manually resizes the i-frame. Please see attached screenshots 2 and 3.

          Michael Saechang added a comment -

          Committed on:
          Plugins 6.2.x GIT ID: 60b2b72789370bda321a9acf6915dd3bca10fc86.

          Sharon Choi added a comment - - edited

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7 + MySQL 5. Portal 6.2.x GIT ID: 64387529a49f594685b964dfc68ea4a37be6b409.
          Plugins 6.2.x GIT ID: 6df5ae3ed7a9e490e4de541aa872635fb531ff05.

          Following the steps in the description, and with the window completely maximized, the drop down menus that display within the Edit Details i-frame are displaying correctly and are no longer cut off on the far right side. The drop down menus are now shifted so that the entire drop down is shifted over to the left, and all options within the drop down are displaying without the need for the user to manually resize the window. The drop down menus also display correctly even with the window not completely maximized to the screen.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 26 weeks, 5 days ago

                Development

                  Structure Helper Panel