PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-31703

Enterprise Calendar - Exception and Error thrown when User has Calendar portlet deployed and clicks Open Private Pages in Control Panel

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE M3
    • Fix Version/s: 6.2.0 CE M5
    • Component/s: Calendar, Collaboration
    • Labels:
      None
    • Environment:
      Tomcat 7 + MySQL 5. Portal 6.2.x GIT ID: 9741331a07b220cba5079904f59267700dd06550.
      Plugins 6.2.x GIT ID: 455ad45725b357b7e30823d263ec0bfb2a93dc60.
    • Fix Priority:
      4
    • Caused by:
      Feature/improvement was not complete
    • Similar Issues:
      Show 4 results 

      Description

      After creating a new user, and clicking on the new user's Personal Site, with propagation of site templates enabled for both the Public and Private Site pages for the user's Personal Site, the Admin user will encounter an exception and error.

      1. Have Enterprise Calendar portlet deployed
      2. Start up Liferay, create a new user in the Control Panel
      3. Click Personal Site, select Community site under Public Pages, select Intranet Site under Private Pages
      4. Flag both checkboxes enabling propagation of changes from the site template
      5. Click Save, click Open Private Pages
      6. User will see the attached exception and error

        Activity

        Sharon Choi added a comment -

        PASSED Manual Testing following the steps in the description.

        Fixed on:
        Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 1c0a4d2885ea6ecc10c4911e4ce3021e2e3bafcd.
        Plugins 6.2.x GIT ID: 8f0c62256aa04704b74412a7bd5773909e980646.

        No console exceptions are thrown anymore when the user clicks Open Private Pages in Control Panel. Everything seems to be working as it should be with site templates enabled and the new Calendar plugin deployed.


          People

          • Assignee:
            Sharon Choi
            Reporter:
            Sharon Choi
            Recent user:
            Randy Zhu
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 50 weeks, 6 days ago

              Development

                Structure Helper Panel