PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-31707

Enterprise Calendar - A regular user is unable to add the calendar to their My Public/Private Pages

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE M3
    • Fix Version/s: 6.2.0 CE M5
    • Labels:
      None
    • Environment:
      Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 77bb304c1378e3a4ac422d4946f2a11bf7513359.
      Plugins 6.2.x GIT ID: 5ee4b3df9fd6747b9686e590e953dcca90a77aab.
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Enterprise Calendar - A regular user is unable to add the calendar to their My Public/Private Pages.

      1. Create a new user.
      2. Log in as the new user.
      3. Click on Go To > My Public Pages.
      4. Click on Add > More...
      5. Type in Calendar to start the search.

      The only calendar that the user can add is the original calendar. When you give the created user the admin role, however, they will be able to see the enterprise calendar listed in the search result.

        Activity

        Albert Lee added a comment -

        PASSED Manual Testing following the steps in the description.

        Reproduced on:

        Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 77bb304c1378e3a4ac422d4946f2a11bf7513359.
        Plugins 6.2.x GIT ID:5ee4b3df9fd6747b9686e590e953dcca90a77aab.
        The Enterprise Calendar is not listed when adding portlets on both a Users's Public and Private Page.

        Fixed on:
        Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 868900c033545f04cc3347b197e9f30ecbe1eac.
        Plugins 6.2.x GIT ID: 4c3428cde48b57181177cdf0666f1a4c1a00ebe.
        I am able to add the Enterprise Calendar on both a Users's Public and Private Page.


          People

          • Assignee:
            Albert Lee
            Reporter:
            Mandy Lee
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 46 weeks, 5 days ago

              Development

                Structure Helper Panel