PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-31800

Enterprise Calendar - An extra day is appended for imported All Day Events

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE M3
    • Fix Version/s: 6.2.0 CE M5
    • Labels:
      None
    • Environment:
      Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 9741331a07b220cba5079904f59267700dd06550.
      Plugins 6.2.x GIT ID: 9e05b4833868eccf34e2f053890e1305fd5700bd.
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      When importing an ics that contains All Day Events, an extra day is appended to the All Day Event in the calendar.

        Activity

        Sharon Choi added a comment -

        PASSED Manual Testing using the following steps:

        1. Create a repeating All Day Event in Google Calendar
        2. Export the Google Calendar as an .ics file
        3. In the Calendar portlet, import the .ics file into a new calendar
        4. Assert that all events are imported correctly

        Fixed on:
        Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 35cd8d8c296890e510c143c76e5e81a21d0a2aed.
        Plugins 6.2.x GIT ID: 6ac59e95ad24ef44f6869cfd05b74d4f56aa58c5.

        The imported ics file seems to be imported correctly now, and extra days are no longer appended to the imported All Day Events.


          People

          • Assignee:
            Sharon Choi
            Reporter:
            Albert Lee
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 3 weeks, 2 days ago

              Development

                Structure Helper Panel