PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-31815

Child page can't be published to Remote Staging if the parent is not already published

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.1 CE GA2, 6.1.20 EE GA2
    • Fix Version/s: 6.1.30 EE GA3, 6.2.0 CE M4
    • Component/s: WCM Staging
    • Labels:
    • Environment:
      2 tomcat-bundles with mysql
    • Branch Version/s:
      6.1.x
    • Backported to Branch:
      Committed
    • Story Points:
      4
    • Similar Issues:
      Show 4 results 

      Description

      When Staging-Remote is enabled and you publish a child page which parent are not already published an error is retrieved (The page could not be found) and the page is not published.

      Steps to reproduce:

      1. Start both servers.
      2. Create the Origin Site (OS) and Destination Site (DS) in the respective servers.
      3. In OS: Enable Staging Remote in site configuration with the parameters of DS (URL, port, siteId)
      4. In OS: Create three pages: home page (PH), page 1 (P1), and a page 2 (P2) as child of P1.
      5. In OS: Go to PH, click in publish to remote site, change selection and only select PH

      • Result Ok. The page is published to DS.

      6. In OS: Go to P2, click in publish to remote site, change selection and only select P2, make sure that publish ancestor if necessary is checked.

      • Result Error. The page could not be found, and the page is not published to DS.

      Caused by:
      The method that retrieves the not-published parents com.liferay.portal.staging.StagingImpl.getMissingParentLayouts(Layout, long) doesn't work properly with Remote Staging.

        Activity

        Jose Jimenez added a comment -

        I think the PR was for the ticket LPS-31851 and not for this one.

        Mark Jin added a comment -

        PASSED Manual Testing following the steps in the description.

        Reproduced on:
        Tomcat 7.0 + MySQL 5. Portal 6.1.20 EE GA2.

        The page could not be found, and the page is not published to DS.

        Fixed on:
        Tomcat 7.0 + MySQL 5. Portal 6.1.x EE GIT ID: 247512b68091c563a1416c297e35887eeaddc23e.
        Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 3f94115ce4832ccceeb7926ab495a46e360cd5da.

        Publish child page to remote server works fine.


          People

          • Assignee:
            Mark Jin
            Reporter:
            Jose Jimenez
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 1 week, 5 days ago

              Development

                Structure Helper Panel