PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-31921

Enterprise Calendar - Creating an All Day Event under the Edit Details i-frame, causes event to change event time and appends extra days

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE M3
    • Fix Version/s: 6.2.0 CE M5
    • Component/s: Calendar, Collaboration
    • Labels:
      None
    • Environment:
      Tomcat 7 + MySQL 5. Portal 6.2.x GIT ID: b8b08350ea430cb0b6a601d1b88a3272436efaad.
      Plugins 6.2.x GIT ID: 34a7c2a7bec952c4e1a538cc0c8f625a9cd9d606.
    • Fix Priority:
      4
    • Caused by:
      Unknown
    • Similar Issues:
      Show 5 results 

      Description

      When creating an All Day Event under the Edit Details i-frame, the All Day Event is created incorrectly, and will append extra days to the event created, in addition to changing the time of the event to be 4:00PM - 3:59PM when the standard is 12:00AM - 11:59PM. No errors display on the console.

      1. Create an event by clicking and dragging from any start time to an end time a few hours later under the day or week view
      2. Click Edit Details
      3. Flag All Day Event, click Save, click Close
      4. Assert that All Day Event creates (here you will see that All Day Event spans multiple days)
      5. Click on the event (here you will see that the time is set to 4:00pm - 3:59pm, and the dates of the event is changed)
      6. Create an All Day Event by clicking and dragging within the All Day cell
      7. Click Save
      8. Assert that All Day Event has been properly created
      9. Create an All Day Event by clicking and dragging within the All Day cell on another day
      10. Click Edit Details, Click Save, Click Close
      11. Here you will see that both All Day events created are now multiple day events, which is incorrect
      12. Clicking on both events will display that the event time is set to 4:00pm-3:59pm, which is also incorrect

      It seems that when a user edits or saves anything under the Edit Details i-frame when creating an All Day Event, the events are created incorrectly. Creating an All Day Event that overlaps with another one, will only stack the number of days appended to the earlier All Day Event.

        Issue Links

          Activity

          Sharon Choi added a comment -

          Tried to reproduce the issue while doing RCA for this ticket, but issue can appear inconsistently, depending on the data within the calendar. This issue has come up after a user has created a few users, a few resources, and events, or some permutation of that data input. Something that is consistent that is similar to this issue, is when the user does the following:

          1. User creates an All Day event
          2. User asserts that All Day event has been created correctly
          3. User clicks Edit Details for All Day event, unflags the "All Day" checkbox, clicks Save (here user will see that an extra day has been appended)
          4. User flags the "All Day" checkbox again, clicks Save, clicks Close
          5. User will see that a two-day All Day event has been created
          Adam Brandizzi added a comment -

          A proposed solution to avoid the issoe on converting from and to all-day events. Note that I do not know why the minutes are rounded, so this solution can be unacceptable.

          Adam Brandizzi added a comment -

          Note also that I am solving the problem as related by Sharon's last comment. I could not reproduce the issue as described by the original bug report. If it keeps happening after the new version (supposing that it will be accepted) I will return to this problem.

          Sharon Choi added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 3bac3614607d2f8d8b76955f3e0eb0dcfd050d1e.
          Plugins 6.2.x GIT ID: 6ac59e95ad24ef44f6869cfd05b74d4f56aa58c5.

          Tested per instructions stated on previous comment, and All Day events that are created and modified under the Edit Details i-frame are no longer changing event times nor appending extra days.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 21 weeks, 3 days ago

                Development

                  Structure Helper Panel