PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-31927

Enterprise Calendar - When a user sends an invite, all of the user's and attendee's calendars are shown as users attending the event

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE M3
    • Fix Version/s: 6.2.0 CE B2
    • Component/s: Calendar
    • Labels:
      None
    • Environment:
      Tomcat 7 + MySQL 5. Chrome. Portal 6.2.x: b8b08350ea430cb0b6a601d1b88a3272436efaad.
      Plugins 6.2.x: 34a7c2a7bec952c4e1a538cc0c8f625a9cd9d606.
    • Fix Priority:
      5
    • Similar Issues:
      Show 5 results 

      Description

      If a user has several calendars listed under 'My Calendar' and that user sends an invite to another user, in the invite, all of the user's calendar will be listed as a User attending the event.

      1. Create 2 users, user1 and user2
      2. For user1, create a couple of personal calendars, My Calendars > Add Calendar
      3. Create an event and invite user2
      4. Click on the event and assert that your personal calendars are being shown as Users attending the event

      The event should show only the users default calendar which was invited and not all of the users calendars.

        Activity

        Sharon Choi added a comment -

        PASSED Manual Testing following the steps in the description.

        Fixed on:
        Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: fd5d739049d82becad39f66ff7c273d138911359.
        Plugins 6.2.x GIT ID: 1adb4ed66fa3691080541f240303cd9304ae88c0.

        Now, when a user sends an invite, only the default user and invited attendee's calendars display.


          People

          • Assignee:
            Sharon Choi
            Reporter:
            Albert Lee
            Recent user:
            Randy Zhu
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 36 weeks, 6 days ago

              Development

                Structure Helper Panel