Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-32582

Color Scheme selection doesn't handle the device when it should use the default Color Scheme

    Details

    • Story Points:
      3

      Description

      When changing themes, in that case when wap theme has no color schemes the regular device's default color scheme id will be propagated into the DB even though a default value is specified for the wap themes.

      Steps to reproduce:

      1. Set the following properties in portal-ext.properties:
        default.regular.color.scheme.id=03
        default.wap.color.scheme.id=04
        
      2. Deploy a new theme where the wap theme has no color schemes defined
      3. Select the new theme for a Site and save it
      4. Verify layoutset table in the DB

      Expected behaviour: in the wapColorSchemeId column the value should be 04
      Actual behaviour: in the wapColorSchemeId column the value is 03

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mark.jin Mark Jin (Inactive)
                Reporter:
                vilmos.papp Vilmos Papp
                Participants of an Issue:
                Recent user:
                Esther Sanz
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  4 years, 10 weeks, 5 days ago