PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-32705

6.1.10.1 - Social Networking - Request Portlet does not appear and does not restrict the Add Friend function on the Wall portlet

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 6.1.1 CE GA2, 6.1.20 EE GA2
    • Fix Version/s: 6.1.1 CE GA2, 6.1.20 EE GA2
    • Component/s: Collaboration
    • Labels:
      None
    • Environment:
      Tomcat 7 + MySQL 5. Portal 6.1.10 EE GA1. Plugins 6.1.10 EE GA1.
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      When a user who is not a friend sees the Wall portlet initially, the message should say only: "You have to Test's friend to access his wall." It should not have "Ask Test to be your friend" as a function. At the latest 6.1.x EE head, this has been fixed. The issue is found at the shelf being tested for 6.1.10.1.

      Secondly, the Request portlet should appear in a minimized form (see the screenshot) Look carefully for "antrage" (German for Request) on the first screenshot. It does not appear in the second image.

      Steps taken:

      1. Deploy the social-networking-plugin.
      2. Go to > My Public Pages
      3. Add a page.
      4. Add the Friends, Friends' Activities, Wall, and Request portlet.
      5. The Request Portlet should appear in a minimized form.
      6. Create a user called test1.
      7. Sign out of system admin.
      8. Go to the guest log in view on the page using the Friendly URL (e.g. localhost:8080/web/test/social-pages-1)
      9. Sign in as test1.
      10. The Wall portlet should say only: "You have to be Test's friend to access his wall."
      11. The Reports portlet should appear.
      1. antrage.jpg
        37 kB
      2. ask-friend.JPG
        48 kB
      3. klein-antrage.jpg
        40 kB

        Activity

        Justin Choi added a comment -

        This issue is working in the following environments:
        6.1.x EE, 6.1.20
        6.2.x

        Sherry Yang added a comment -

        Here is what I found. Request portlet is not in social networking portlet. It is out of box of portal.

        In that case, we need to make a patch for customer portal.


          People

          • Assignee:
            Sherry Yang
            Reporter:
            Justin Choi
            Recent user:
            Randy Zhu
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 3 weeks, 3 days ago

              Development

                Structure Helper Panel