Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.20 EE GA2, 6.2.0 CE M4
    • Fix Version/s: 6.1.X EE, 6.2.X EE
    • Labels:
    • Environment:
      LIFERAY VERSION: 6.1 GA 1
      OPERATING SYSTEM: Windows7
      APPLICATION SERVER: Tomcat 7.0.x
      JAVA VIRTUAL MACHINE: Java 6
      DATABASE: MYSQL 5.1
    • Branch Version/s:
      6.2.x, 6.1.x
    • Backported to Branch:
      Committed
    • Story Points:
      10
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Tag suggestions button doesn't work for the Bookmarks, Documents and Media and the Calendar portlets neither.
      Steps to reproduce:

      1) Have a Document and Media on a page
      2) Add -> e.g. Basic Document
      3) Fill the description field with: "Italian sculptors and painters of the renaissance favored the Virgin Mary for inspiration"
      4) Click on the suggestion button

      Observed behavior: You won't get any suggestions
      Expected behavior: Just like in the Wiki or in the Web content portlet, when you fill the "Content field" and go to the Categorization -> Suggestion button you should have some suggested tags, but in these cases, we should expect it based on the item's Description field.

        Issue Links

          Activity

          Julio Camarero added a comment -

          Just started reviewing :)

          Sent from GH.

          Felix Zhang added a comment -

          PASSED Manual Testing using the following steps:

          Case 1:

          1. Add Bookmark Portlet to the page.
          2. Click Add Bookmark.
          3. Enter Test Bookmark in the Name Field.
          4. Enter http://localhost:8080 in the URL(Required) Field.
          5. Fill the Description Field with: "Italian sculptors and painters of the renaissance favored the Virgin Mary for inspiration".
          6. Click Suggestions button near the Categorization.

          Case 2:

          1. Add Document and Media Portlet to the page.
          2. Click Add -> Basic Document.
          3. Enter Test Document in the Title Field.
          4. Fill the Description Field with: "Italian sculptors and painters of the renaissance favored the Virgin Mary for inspiration".
          5. Click Suggestions button near the Categorization.

          Case 3:

          1. Add the Calendar Portlet to the page.
          2. Click Add Event.
          3. Enter the Test Event in the Title Field.
          4. Fill the description field with: "Italian sculptors and painters of the renaissance favored the Virgin Mary for inspiration".
          5. Click Suggestions button near the Categorization.

          Fixed on:
          Tomcat 7.0 + MySQL 5. Portal master GIT ID: 9a385c7a95b365e4da05dd1972cb00227c780a12.
          Plugins master GIT ID: ce606cafc51ac8625a1698fe8c9aeec10fcf2050.
          Tomcat 7.0 + MySQL 5. Portal ee-6.2.x EE GIT ID: 61f1a0331a75624b037d435eaad9ddd68c9db5a6.
          Plugins 6.2.x EE GIT ID: 73a0528cdc720918ec50b68eed0e8b49a2ccd736.

          When you fill the "Description field" and go to the Categorization -> Suggestion button you will have some suggested tags.

          Felix Zhang added a comment -

          Sending an email to developer for help.

          Felix Zhang added a comment -

          PASSED Manual Testing following the steps in above comment.

          Fixed on:
          Tomcat 7.0.40 + MySQL 5.5.21. Portal 6.1.x EE GIT ID: 8cd2a17d81192e70eac2aa0735c106f115718627.

          AssetTags suggestion can work well in Calendar Portlet, Documents and Media Portlet and Bookmark Portlet.

          Joseph Chin added a comment - - edited

          PASSED Manual Testing using the following steps:

          1. Add the Calendar Portlet to the page
          2. Click Add Event
          3. Enter the Test Event in the Title Field
          4. Fill the description field with: "Italian sculptors and painters of the renaissance favored the Virgin Mary for inspiration"
          5. Click Suggestions button near the Categorization

          Fixed on:
          Tomcat 7.0.42 + MySQL 5.5. Portal 6.2.0 CE GA1.
          Plugins 6.2.x GIT ID: f2037ddb7e3b2d357ef2ed676d3537dcf9b9d52f.
          Tomcat 7.0.42 + MySQL 5.5. Portal 6.2.10 EE GA1.
          Plugins ee-6.2.10 GIT ID: d8a7e697e776b53d59ef49c52f0ef3324c54a2a2.

          When you fill the "Description field" and go to the Categorization -> Suggestion button you will have some suggested tags.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 33 weeks ago

                Development

                  Structure Helper Panel