PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-32917

Kaleo - The Update task does not show up after rejecting a task that is in Review

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE M4
    • Fix Version/s: 6.2.0 CE M4
    • Labels:
      None
    • Environment:
      Tomcat 7.0.34 + MySQL 5. Portal 6.2.x GIT ID: fbbe0bdcdbb2e286819b5676a119e42c82f07d04.
      Plugins 6.2.x GIT ID: 4f2a9d26c027c856f53c1293ac5fd2c931a4cd38.
    • Fix Priority:
      4
    • Similar Issues:
      Show 4 results 

      Description

      Steps to reproduce:

      1. Deploy Kaleo Web plugin
      2. Navigate to Control Panel > Workflow Configuration and select 'Single Approver (Version 1)' for Web Content
      3. Navigate to Control Panel > Web Content and add a Basic Web Content called WebContent and click 'Submit for Publication'
      4. Navigate to Control Panel > Workflow and then Submissions > Pending
      5. Click on WebContent
      6. Click on 'Assign to me' and then OK
      7. While still in WebContent, click on Actions > Reject and than OK
      8. Wait for one minute and refresh the page
        • The Update task does not appear.
      9. Click Back to Liferay
      10. Navigate back to Control Panel > Workflow and then Submissions > Pending and click on WebContent
        • The Update task does not appear.

      Console errors also appear:

      19:16:43,928 ERROR [liferay/kaleo_graph_walker-1][ParallelDestination:71] Unable to process message {destinationName=liferay/kaleo_graph_walker, response=null, responseDestinationName=null, responseId=null, payload=com.liferay.portal.workflow.kaleo.runtime.graph.PathElement@417cd3d2, values={permiss
      ionChecker=com.liferay.portal.kernel.util.TransientValue@6a36a194, principalName=2, companyId=1}}
      com.liferay.portal.kernel.messaging.MessageListenerException: com.liferay.portal.workflow.kaleo.runtime.notification.NotificationMessageGenerationException: Unable to generate notification message
              at com.liferay.portal.kernel.messaging.BaseMessageListener.receive(BaseMessageListener.java:31)
              at com.liferay.portal.kernel.messaging.InvokerMessageListener.receive(InvokerMessageListener.java:63)
              at com.liferay.portal.kernel.messaging.ParallelDestination$1.run(ParallelDestination.java:68)
              at com.liferay.portal.kernel.concurrent.ThreadPoolExecutor$WorkerTask._runTask(ThreadPoolExecutor.java:675)
              at com.liferay.portal.kernel.concurrent.ThreadPoolExecutor$WorkerTask.run(ThreadPoolExecutor.java:586)
              at java.lang.Thread.run(Thread.java:722)
      Caused by: com.liferay.portal.workflow.kaleo.runtime.notification.NotificationMessageGenerationException: Unable to generate notification message
              at com.liferay.portal.workflow.kaleo.runtime.notification.TemplateNotificationMessageGenerator.generateMessage(TemplateNotificationMessageGenerator.java:78)
              at com.liferay.portal.workflow.kaleo.runtime.notification.NotificationUtil._sendKaleoNotification(NotificationUtil.java:58)
              at com.liferay.portal.workflow.kaleo.runtime.notification.NotificationUtil.sendKaleoNotifications(NotificationUtil.java:44)
              at com.liferay.portal.workflow.kaleo.runtime.node.BaseNodeExecutor.exit(BaseNodeExecutor.java:122)
              at com.liferay.portal.workflow.kaleo.runtime.graph.DefaultGraphWalker.follow(DefaultGraphWalker.java:50)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.lang.reflect.Method.invoke(Method.java:601)
              at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:320)
              at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:183)
              at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:150)
              at com.liferay.portal.spring.transaction.TransactionInterceptor.invoke(TransactionInterceptor.java:80)
              at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
              at org.springframework.aop.interceptor.ExposeInvocationInterceptor.invoke(ExposeInvocationInterceptor.java:90)
              at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
              at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:202)
              at $Proxy471.follow(Unknown Source)
              at com.liferay.portal.workflow.kaleo.runtime.graph.messaging.PathElementMessageListener.doReceive(PathElementMessageListener.java:54)
              at com.liferay.portal.kernel.messaging.BaseMessageListener.receive(BaseMessageListener.java:25)
              ... 5 more
      Caused by: com.liferay.portal.kernel.template.TemplateException: Unsupported template manager FREEMARKER
              at com.liferay.portal.kernel.template.TemplateManagerUtil._getTemplateManager(TemplateManagerUtil.java:181)
              at com.liferay.portal.kernel.template.TemplateManagerUtil.getTemplate(TemplateManagerUtil.java:87)
              at com.liferay.portal.workflow.kaleo.runtime.notification.TemplateNotificationMessageGenerator.generateMessage(TemplateNotificationMessageGenerator.java:64)
              ... 24 more
      

      Expected result:
      The Update task should appear under Tasks after rejecting the task that is in Review.

      Actual result:
      The Update task does not appear. This issue is different from LPS-28064, because even after waiting or refreshing the page the Update task still does not appear (see Michael Han's comment).

        Issue Links

          Activity

          Kenji Heigel added a comment -

          This issue seems to be part of a bigger kaleo workflow issue. The reviewer cannot Approve or Reject the task without getting the console errors described in the description, and the tasks do not appear to be approved or rejected as they normally should be. In LPS-32929, Documents and Media documents and Blogs entries still have Pending status after being approved.

          Kenji Heigel added a comment -

          Caused by LPS-32688:
          Portal 6.2.x GIT ID: a31b5d57b283a4bdba96b33511609a8611f307fe.

          This regression is caused by a portal commit, not a commit to plugins. When doing root cause analysis, the following plugin GIT ID was used in all test cases:

          Plugins 6.2.x GIT ID: 2e450671bd2de81e051fd7fcc939cc66e2eb605d.

          Kenji Heigel added a comment -

          Committed on:
          Plugins 6.2.x GIT ID: d9ed7403a42a4eeac157e553588d013f2c4e0cd1.

          Kenji Heigel added a comment - - edited

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0.34 + MySQL 5. Portal 6.2.x GIT ID: 8fab771f4d55caa948ca1f6595347b2b328c5515.
          Plugins 6.2.x GIT ID: a0e827c50c3a7048ce54d90d8a4c5e8f43de9d67.

          The task that the user rejects now has a status of Update. Additionally, the general workflow of approving and rejecting tasks is working. No console errors occur. This should also fix LPS-32929.


            People

            • Assignee:
              Kenji Heigel
              Reporter:
              Kenji Heigel
              Recent user:
              Esther Sanz
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 6 weeks, 1 day ago

                Development

                  Structure Helper Panel