PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-33048

Documents and Media - When editing a Document Type, the diagram builder canvas is blank when the edit window comes up

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE M4
    • Fix Version/s: 6.2.0 CE M5
    • Component/s: DM
    • Labels:
      None
    • Environment:
      Tomcat 7.0.34 + MySQL 5. Portal 6.2.x GIT ID: 2a04b1292782b1d0be60152b33153d7508c100b0.
    • Fix Priority:
      5
    • Caused by:
      Another new feature
    • Similar Issues:
      Show 5 results 

      Description

      This doesn't happen in ee-6.1.x. In ee-6.1.x, the original fields are present when editing a document type.

      Steps to reproduce:

      1. Go to Control Panel > Documents and Media
      2. Click Manage > Document Types and add a Document Type with a Boolean field
      3. Click on the actions menu next to the created document type and click Edit
        • The boolean field won't be there, and there will be a Metadata field at the bottom that has the same name as the document type

      Expected result:
      The boolean field should be present in the build canvas. All the original fields ought to be there as this makes it easy for the user to edit the existing document type. There also shouldn't be any metadata fields because the user didn't add one when creating the document type.

      Actual result:
      The build canvas is empty, and there is a metadata field that has the same name as the document type.

        Issue Links

          Activity

          Brian Chiu added a comment -

          This issue is caused by LPS-32875.

          Working as of:
          Tomcat 7.0.34 + MySQL 5. Portal 6.2.x GIT ID: 85b610beac9c9ebbae386e57dbd370c6317ae769.

          Git bisect output:

          There are only 'skip'ped commits left to test.
          The first bad commit could be any of:
          5efc35e2e788b7a61a2b23f264ea4973acb39c40
          39c5adae2567fa525f47dfa75311307d008397f5
          fa8c7c310f274b7ebe753e45c575957b6b00fa87
          0e7eb9e265881938b82098fc41d726d3884db7da
          d92ffa3debdbf93cdc2ff34f5fe3a7c517c028c3
          5284212f1af819953092aa7f0c0dc3bd8bf4cb69
          9769fa8191c814306c80d7cc5d82ff43d43c51f0
          3fb1b4caf689dc3801be1ec5e3f2b9515c14bcad
          We cannot bisect more!
          Brian Chiu added a comment -

          Committed on:
          Portal 6.2.x GIT ID: 6fa3715b5e2e5979efc18761e13440aea503ea26.

          Brian Chiu added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0.34 + MySQL 5. Portal 6.2.x GIT ID: 6df5aee2564533c9c42f02ca89cbac504c0f7a6f.

          The build canvas now has all the fields that were originally there.


            People

            • Assignee:
              Brian Chiu
              Reporter:
              Brian Chiu
              Recent user:
              Randy Zhu
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 6 weeks, 5 days ago

                Development

                  Structure Helper Panel