PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-33173

Workflow could not be set to folders when scope of document and media portlet is configured to page

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.1.1 CE GA2, 6.1.20 EE GA2, 6.2.0 CE RC1, 6.2.0 CE RC2
    • Fix Version/s: 6.2.0 CE RC2
    • Component/s: Workflow
    • Labels:
    • Environment:
      Tomcat 7.0 + MySQL 5. Portal master GIT ID: c87383d2ad2938970df8ddb54322cc6d44b3cc5a.
      Plugins master GIT ID: 6bdd4d81b1fc9c4d8144922d26262629fe2b4217.
    • Story Points:
      2
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Please make sure that you deployed kaleo-web plugin.

      Reproduction steps are below:

      1. add document and media porlet to a page.
      2. click config icon of the portlet.
      3. move to scope tab.
      4. set scope as Select Page and Scoped page as Current page.
      5. add a folder to the portlet.
      6. click edit menu of the added folder
      7. choose 'Define specific doument type restrictions and workflows for this folder' and set Simple Approver as Default workflow.
      8. Click save.

      Then,
      click edit menu again, no workflow is chosen nor if you add a document, no workflow applied.

        Issue Links

          Activity

          Ginson Ren added a comment -

          PASSED Manual Testing following the steps in the description.

          Reproduced on:
          Tomcat 7.0 + MySQL 5. Portal 6.1.20 EE GA2.

          Click edit menu again, no workflow is chosen and no workflow applied if you add a document.

          Fixed on:
          Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: f317fb8d042572b386b832d573bb52803cd0d161.
          Plugins 6.2.x EE GIT ID: bfb1725f10ed0be62a450afea1520c468a63181d.

          Click edit menu again, workflow is chosen and the workflow works well when you add a document.

          Brian Chan added a comment -

          Rolled back because they break tests.

          Tammy Fong added a comment - - edited

          A shorter test case to reproduce the issue is:

          1. Deploy kaleo-web.
          2. Add a document and media portlet to a page/go to contents of control panel
          3. Click the downward arrow in Home, then click edit.
          4. Select 'Single Approver (Version 1)' in the Default Workflow for all Document Types drop down
          5. Save
          6. Then click edit again

          Expected result:
          It displayed 'Single Approver (Version 1)' in the Default Workflow for all Document Types drop down.

          Actual result:
          It displayed 'No Workflow' in the Default Workflow for all Document Types drop down.

          Reproduced on:
          Tomcat 7.0 + MySQL 5. Portal master GIT ID: c87383d2ad2938970df8ddb54322cc6d44b3cc5a.
          Plugins master GIT ID: 6bdd4d81b1fc9c4d8144922d26262629fe2b4217.

          Shitian "Shelton" Zhang added a comment -

          No Longer Reproducible on:
          Tomcat 7.0 + MySQL 5. Portal master GIT ID: 8cbad49fb75d428f55e16202dcf52e4cde038bc0.
          Plugins master GIT ID: c7fc4b55de8dd9de49c61bbe080a61df87a6874b.

          When set workflow to folders, it can be configured successfully.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 30 weeks, 4 days ago

                Development

                  Structure Helper Panel