PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-33271

Google Analytics tracking isn't recognized by GA w/ default MinifierFilter and/or StripFilter

    Details

    • Similar Issues:
      Show 5 results 

      Description

      Google Analytics tracking code is not recognized by GA with the default portal configuration. The tracking status remained "Not Installed" until I disabled MinifierFilter and StripFilter in portal-ext.properties:

      portal-ext.properties
      com.liferay.portal.servlet.filters.minifier.MinifierFilter=false
      com.liferay.portal.servlet.filters.strip.StripFilter=false
      

      After the tracking token is recognized by GA, filters can be enabled again and traking seems to work just fine.

        Activity

        Hide
        Mika Koivisto added a comment -

        I can confirm the problem as I just ran into it myself on 6.1 GA2.

        Show
        Mika Koivisto added a comment - I can confirm the problem as I just ran into it myself on 6.1 GA2.
        Hide
        Vilmos Kozma added a comment -

        The same for me. However, I coudn't make it work with these url params: &js_fast_load=0&css_fast_load=0&strip=0

        Show
        Vilmos Kozma added a comment - The same for me. However, I coudn't make it work with these url params: &js_fast_load=0&css_fast_load=0&strip=0
        Hide
        Nilesh Gundecha added a comment -

        I can see this bug in early Liferay 6.1 build also.

        Show
        Nilesh Gundecha added a comment - I can see this bug in early Liferay 6.1 build also.

          People

          • Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Days since last comment:
              1 year, 49 weeks, 6 days ago

              Development

                Structure Helper Panel