Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE M5
    • Fix Version/s: 6.2.0 CE M5
    • Labels:
    • Environment:
      Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 37130cb4a85e8de2545613dc54bc8aa7378d3635.
      Plugins 6.2.x EE GIT ID: 3fee33553c13d960a381e16c1ba941f995ff9436.
    • Fix Priority:
      5
    • Similar Issues:
      Show 2 results 

      Description

      Steps to reproduce:
      1. Go to liferay-plugins/webs/vldap-web
      2. Run ant all.

      F:\Git\liferay-portal-ee\plugins\webs\vldap-web>ant all
      Buildfile: F:\Git\liferay-portal-ee\plugins\webs\vldap-web\build.xml
      
      all:
      
      clean:
         [delete] Deleting directory F:\Git\liferay-portal-ee\plugins\webs\vldap-web\docroot\WEB-INF\classes
      
      clean-portal-dependencies:
      
      compile:
      
      merge:
          [mkdir] Created dir: F:\Git\liferay-portal-ee\plugins\webs\vldap-web\docroot\WEB-INF\classes
           [copy] Copying 4 files to F:\Git\liferay-portal-ee\plugins\webs\vldap-web\docroot\WEB-INF\lib
           [copy] Copying 5 files to F:\Git\liferay-portal-ee\plugins\webs\vldap-web\docroot\WEB-INF\lib
      
      compile-java:
           [copy] Copying 3 files to F:\Git\liferay-portal-ee\plugins\webs\vldap-web\docroot\WEB-INF\classes
           [copy] Copied 12 empty directories to 11 empty directories under F:\Git\liferay-portal-ee\plugins\webs\vldap-web\docroot\WEB-INF\classes
          [javac] Compiling 57 source files to F:\Git\liferay-portal-ee\plugins\webs\vldap-web\docroot\WEB-INF\classes
          [javac] ----------
          [javac] 1. ERROR in F:\Git\liferay-portal-ee\plugins\webs\vldap-web\docroot\WEB-INF\src\com\liferay\vldap\server\directory\builder\CommunityBuilder.java (at line 132)
          [javac]     GroupLocalServiceUtil.search(
          [javac]                           ^^^^^^
          [javac] The method search(long, String, LinkedHashMap<String,Object>, int, int, OrderByComparator) in the type GroupLocalServiceUtil is not applicable for the arguments (long, String, 
      
      String, null, int, int)
          [javac] ----------
          [javac] ----------
          [javac] 2. ERROR in F:\Git\liferay-portal-ee\plugins\webs\vldap-web\docroot\WEB-INF\src\com\liferay\vldap\server\directory\ldap\UserDirectory.java (at line 87)
          [javac]     List<Group> groups = GroupLocalServiceUtil.search(
          [javac]                                                ^^^^^^
          [javac] The method search(long, long[], long, String, LinkedHashMap<String,Object>, int, int) in the type GroupLocalServiceUtil is not applicable for the arguments (long, long[], null, 
      
      null, LinkedHashMap<String,Object>, int, int)
          [javac] ----------
          [javac] 2 problems (2 errors)
      
      BUILD FAILED
      F:\Git\liferay-portal-ee\plugins\build-common-plugin.xml:98: The following error occurred while executing this line:
      F:\Git\liferay-portal-ee\plugins\build-common-plugin.xml:677: The following error occurred while executing this line:
      F:\Git\liferay-portal-ee\plugins\build-common.xml:95: Compile failed; see the compiler error output for details.
      
      Total time: 3 seconds
      

      It's working well for Plugins 6.1.x EE.

        Issue Links

          Activity

          Sophia Zhang added a comment - - edited

          Working as of:
          Plugins 6.2.x EE GIT ID: 29d1834188d05ba02856f201940bc84f0c3efbb6.

          The fixed ticket is LPS-16267 – Can't use vldap-web for group import

          Sophia Zhang added a comment -

          PASSED Manual Testing following the steps in the description.

          Reproduced on:
          Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 37130cb4a85e8de2545613dc54bc8aa7378d3635.
          Plugins 6.2.x EE GIT ID: 3fee33553c13d960a381e16c1ba941f995ff9436.

          Vldap plugin fails to compile.

          Fixed on:
          Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 4474b0e18f4469cae06b12cf8615f46a01a407e7.
          Plugin 6.2.X EE GIT ID: 09a370c07c2543489d1475f30574e075d05fd720.

          Vldap plugin compiles successfully.


            People

            • Assignee:
              Sophia Zhang
              Reporter:
              Sophia Zhang
              Recent user:
              Randy Zhu
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 6 weeks, 2 days ago

                Development

                  Structure Helper Panel