PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-33888

Kaleo Deployment - "scriptingContextBuilder" error and kaleo portlets do not appear in control panel

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.30 EE GA3, 6.2.0 CE M5
    • Labels:
      None
    • Environment:
    • Similar Issues:
      Show 2 results 

      Description

      This occurs in ee-6.1.x and 6.2.x

      Steps to reproduce:

      1. Deploy kaleo-web
        • The following will appear in the console. If the user navigates to the control panel, the kaleo portlets will not be there.
      17:18:42,578 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][AutoDeployDir:164] Processing kaleo-web-6.2.0.1.war
      17:18:42,582 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][HookAutoDeployListener:48] Copying hook plugin for C:\Users\liferay\liferay\deploy\kaleo-web-6.2.0.1.war
      17:18:42,607 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:834] Deploying kaleo-web-6.2.0.1.war
        Expanding: C:\Users\liferay\liferay\deploy\kaleo-web-6.2.0.1.war into L:\private\master-bundles\tomcat-7.0.34\temp\20130320171842639
        Copying 1 file to L:\private\master-bundles\tomcat-7.0.34\temp\20130320171842639\WEB-INF\classes
        Copying 1 file to L:\private\master-bundles\tomcat-7.0.34\temp\20130320171842639\WEB-INF\classes
      17:18:43,724 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:2284] Modifying Servlet 2.4 L:\private\master-bundles\tomcat-7.0.34\temp\20130320171842639\WEB-INF\web.xml
        Copying 868 files to L:\private\master-bundles\tomcat-7.0.34\webapps\kaleo-web
        Copying 1 file to L:\private\master-bundles\tomcat-7.0.34\webapps\kaleo-web
        Deleting directory L:\private\master-bundles\tomcat-7.0.34\temp\20130320171842639
      17:18:44,726 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][HookAutoDeployListener:54] Hook for C:\Users\liferay\liferay\deploy\kaleo-web-6.2.0.1.war copied successfully. Deployment will start in a few seconds.
      17:18:44,729 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][WebAutoDeployListener:48] Copying web plugin for C:\Users\liferay\liferay\deploy\kaleo-web-6.2.0.1.war
      17:18:44,736 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:834] Deploying kaleo-web-6.2.0.1.war
      17:18:44,736 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:937] Updating Kaleo Workflow from version 6.2.0 to version 6.2.0.1
        Expanding: C:\Users\liferay\liferay\deploy\kaleo-web-6.2.0.1.war into L:\private\master-bundles\tomcat-7.0.34\temp\20130320171844737
        Copying 1 file to L:\private\master-bundles\tomcat-7.0.34\temp\20130320171844737\WEB-INF
        Copying 1 file to L:\private\master-bundles\tomcat-7.0.34\temp\20130320171844737\WEB-INF\classes
        Copying 1 file to L:\private\master-bundles\tomcat-7.0.34\temp\20130320171844737\WEB-INF\classes
      17:18:45,323 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:2284] Modifying Servlet 2.4 L:\private\master-bundles\tomcat-7.0.34\temp\20130320171844737\WEB-INF\web.xml
        Copying 869 files to L:\private\master-bundles\tomcat-7.0.34\webapps\kaleo-web
        Copying 1 file to L:\private\master-bundles\tomcat-7.0.34\webapps\kaleo-web
        Deleting directory L:\private\master-bundles\tomcat-7.0.34\temp\20130320171844737
      Mar 20, 2013 5:18:45 PM org.apache.catalina.startup.HostConfig deployDirectory
      INFO: Deploying web application directory L:\private\master-bundles\tomcat-7.0.34\webapps\kaleo-web
      17:18:45,914 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][WebAutoDeployListener:54] Web plugin for C:\Users\liferay\liferay\deploy\kaleo-web-6.2.0.1.war copied successfully. Deployment will start in a few seconds.
      17:18:46,988 INFO  [localhost-startStop-2][HotDeployImpl:178] Deploying kaleo-web from queue
      17:18:46,991 INFO  [localhost-startStop-2][PluginPackageUtil:1044] Reading plugin package for kaleo-web
      Loading file:/L:/private/master-bundles/tomcat-7.0.34/temp/0-kaleo-web/WEB-INF/classes/portlet.properties
      Loading file:/L:/private/master-bundles/tomcat-7.0.34/temp/0-kaleo-web/WEB-INF/classes/service.properties
      17:18:47,079 INFO  [localhost-startStop-2][ServiceComponentLocalServiceImpl:252] Running Kaleo SQL scripts
      Loading file:/L:/private/master-bundles/tomcat-7.0.34/temp/0-kaleo-web/WEB-INF/classes/portlet.properties
      Mar 20, 2013 5:18:47 PM org.apache.catalina.core.ApplicationContext log
      INFO: Initializing Spring root WebApplicationContext
      Loading file:/L:/private/master-bundles/tomcat-7.0.34/temp/0-kaleo-web/WEB-INF/classes/service.properties
      Loading file:/L:/private/master-bundles/tomcat-7.0.34/temp/0-kaleo-web/WEB-INF/classes/service.properties
      17:18:49,516 ERROR [localhost-startStop-2][ContextLoader:185] Context initialization failed
      org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderUtil' defined in ServletContext resource [/WEB-INF/classes/META-INF/kaleo-spring.xml]: Initialization of bean failed; nested exception is org.springframework.beans.ConversionNotSupportedException: Failed to convert property value of type 'com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderImpl' to required type 'com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilder' for property 'scriptingContextBuilder'; nested exception is java.lang.IllegalStateException: Cannot convert value of type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderImpl] to required type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilder] for property 'scriptingContextBuilder': no matching editors or conversion strategy found
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:526)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:455)
              at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:293)
              at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
              at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:290)
              at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:192)
              at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:585)
              at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:895)
              at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:425)
              at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:282)
              at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:204)
              at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:47)
              at com.liferay.portal.spring.context.PortletContextLoaderListener.contextInitialized(PortletContextLoaderListener.java:85)
              at com.liferay.portal.deploy.hot.SpringHotDeployListener.doInvokeDeploy(SpringHotDeployListener.java:77)
              at com.liferay.portal.deploy.hot.SpringHotDeployListener.invokeDeploy(SpringHotDeployListener.java:40)
              at com.liferay.portal.deploy.hot.HotDeployImpl.doFireDeployEvent(HotDeployImpl.java:188)
              at com.liferay.portal.deploy.hot.HotDeployImpl.fireDeployEvent(HotDeployImpl.java:97)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.lang.reflect.Method.invoke(Method.java:601)
              at com.liferay.portal.security.lang.DoPrivilegedHandler$InvokePrivilegedExceptionAction.run(DoPrivilegedHandler.java:133)
              at java.security.AccessController.doPrivileged(Native Method)
              at com.liferay.portal.security.lang.DoPrivilegedHandler.invoke(DoPrivilegedHandler.java:65)
              at com.sun.proxy.$Proxy24.fireDeployEvent(Unknown Source)
              at com.liferay.portal.kernel.deploy.hot.HotDeployUtil.fireDeployEvent(HotDeployUtil.java:27)
              at com.liferay.portal.kernel.servlet.PluginContextListener.fireDeployEvent(PluginContextListener.java:159)
              at com.liferay.portal.kernel.servlet.PluginContextListener.doPortalInit(PluginContextListener.java:149)
              at com.liferay.portal.kernel.util.BasePortalLifecycle.portalInit(BasePortalLifecycle.java:42)
              at com.liferay.portal.kernel.util.PortalLifecycleUtil.register(PortalLifecycleUtil.java:64)
              at com.liferay.portal.kernel.util.PortalLifecycleUtil.register(PortalLifecycleUtil.java:56)
              at com.liferay.portal.kernel.util.BasePortalLifecycle.registerPortalLifecycle(BasePortalLifecycle.java:52)
              at com.liferay.portal.kernel.servlet.PluginContextListener.contextInitialized(PluginContextListener.java:111)
              at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4791)
              at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5285)
              at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
              at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
              at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
              at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:633)
              at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1114)
              at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1673)
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
              at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
              at java.util.concurrent.FutureTask.run(FutureTask.java:166)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
              at java.lang.Thread.run(Thread.java:722)
      Caused by: org.springframework.beans.ConversionNotSupportedException: Failed to convert property value of type 'com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderImpl' to required type 'com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilder' for property 'scriptingContextBuilder'; nested exception is java.lang.IllegalStateException: Cannot convert value of type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderImpl] to required type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilder] for property 'scriptingContextBuilder': no matching editors or conversion strategy found
              at org.springframework.beans.BeanWrapperImpl.convertIfNecessary(BeanWrapperImpl.java:481)
              at org.springframework.beans.BeanWrapperImpl.convertForProperty(BeanWrapperImpl.java:518)
              at org.springframework.beans.BeanWrapperImpl.convertForProperty(BeanWrapperImpl.java:512)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.convertForProperty(AbstractAutowireCapableBeanFactory.java:1373)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyPropertyValues(AbstractAutowireCapableBeanFactory.java:1332)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.populateBean(AbstractAutowireCapableBeanFactory.java:1085)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:516)
              ... 46 more
      Caused by: java.lang.IllegalStateException: Cannot convert value of type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderImpl] to required type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilder] for property 'scriptingContextBuilder': no matching editors or conversion strategy found
              at org.springframework.beans.TypeConverterDelegate.convertIfNecessary(TypeConverterDelegate.java:236)
              at org.springframework.beans.BeanWrapperImpl.convertIfNecessary(BeanWrapperImpl.java:466)
              ... 52 more
      17:18:49,541 ERROR [localhost-startStop-2][HotDeployImpl:191] com.liferay.portal.kernel.deploy.hot.HotDeployException: Error initializing Spring for kaleo-web
      com.liferay.portal.kernel.deploy.hot.HotDeployException: Error initializing Spring for kaleo-web
              at com.liferay.portal.kernel.deploy.hot.BaseHotDeployListener.throwHotDeployException(BaseHotDeployListener.java:46)
              at com.liferay.portal.deploy.hot.SpringHotDeployListener.invokeDeploy(SpringHotDeployListener.java:43)
              at com.liferay.portal.deploy.hot.HotDeployImpl.doFireDeployEvent(HotDeployImpl.java:188)
              at com.liferay.portal.deploy.hot.HotDeployImpl.fireDeployEvent(HotDeployImpl.java:97)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.lang.reflect.Method.invoke(Method.java:601)
              at com.liferay.portal.security.lang.DoPrivilegedHandler$InvokePrivilegedExceptionAction.run(DoPrivilegedHandler.java:133)
              at java.security.AccessController.doPrivileged(Native Method)
              at com.liferay.portal.security.lang.DoPrivilegedHandler.invoke(DoPrivilegedHandler.java:65)
              at com.sun.proxy.$Proxy24.fireDeployEvent(Unknown Source)
              at com.liferay.portal.kernel.deploy.hot.HotDeployUtil.fireDeployEvent(HotDeployUtil.java:27)
              at com.liferay.portal.kernel.servlet.PluginContextListener.fireDeployEvent(PluginContextListener.java:159)
              at com.liferay.portal.kernel.servlet.PluginContextListener.doPortalInit(PluginContextListener.java:149)
              at com.liferay.portal.kernel.util.BasePortalLifecycle.portalInit(BasePortalLifecycle.java:42)
              at com.liferay.portal.kernel.util.PortalLifecycleUtil.register(PortalLifecycleUtil.java:64)
              at com.liferay.portal.kernel.util.PortalLifecycleUtil.register(PortalLifecycleUtil.java:56)
              at com.liferay.portal.kernel.util.BasePortalLifecycle.registerPortalLifecycle(BasePortalLifecycle.java:52)
              at com.liferay.portal.kernel.servlet.PluginContextListener.contextInitialized(PluginContextListener.java:111)
              at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4791)
              at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5285)
              at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
              at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
              at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
              at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:633)
              at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1114)
              at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1673)
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
              at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
              at java.util.concurrent.FutureTask.run(FutureTask.java:166)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
              at java.lang.Thread.run(Thread.java:722)
      Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderUtil' defined in ServletContext resource [/WEB-INF/classes/META-INF/kaleo-spring.xml]: Initialization of bean failed; nested exception is org.springframework.beans.ConversionNotSupportedException: Failed to convert property value of type 'com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderImpl' to required type 'com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilder' for property 'scriptingContextBuilder'; nested exception is java.lang.IllegalStateException: Cannot convert value of type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderImpl] to required type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilder] for property 'scriptingContextBuilder': no matching editors or conversion strategy found
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:526)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:455)
              at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:293)
              at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
              at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:290)
              at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:192)
              at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:585)
              at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:895)
              at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:425)
              at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:282)
              at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:204)
              at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:47)
              at com.liferay.portal.spring.context.PortletContextLoaderListener.contextInitialized(PortletContextLoaderListener.java:85)
              at com.liferay.portal.deploy.hot.SpringHotDeployListener.doInvokeDeploy(SpringHotDeployListener.java:77)
              at com.liferay.portal.deploy.hot.SpringHotDeployListener.invokeDeploy(SpringHotDeployListener.java:40)
              ... 32 more
      Caused by: org.springframework.beans.ConversionNotSupportedException: Failed to convert property value of type 'com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderImpl' to required type 'com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilder' for property 'scriptingContextBuilder'; nested exception is java.lang.IllegalStateException: Cannot convert value of type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderImpl] to required type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilder] for property 'scriptingContextBuilder': no matching editors or conversion strategy found
              at org.springframework.beans.BeanWrapperImpl.convertIfNecessary(BeanWrapperImpl.java:481)
              at org.springframework.beans.BeanWrapperImpl.convertForProperty(BeanWrapperImpl.java:518)
              at org.springframework.beans.BeanWrapperImpl.convertForProperty(BeanWrapperImpl.java:512)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.convertForProperty(AbstractAutowireCapableBeanFactory.java:1373)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyPropertyValues(AbstractAutowireCapableBeanFactory.java:1332)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.populateBean(AbstractAutowireCapableBeanFactory.java:1085)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:516)
              ... 46 more
      Caused by: java.lang.IllegalStateException: Cannot convert value of type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilderImpl] to required type [com.liferay.portal.workflow.kaleo.runtime.util.ScriptingContextBuilder] for property 'scriptingContextBuilder': no matching editors or conversion strategy found
              at org.springframework.beans.TypeConverterDelegate.convertIfNecessary(TypeConverterDelegate.java:236)
              at org.springframework.beans.BeanWrapperImpl.convertIfNecessary(BeanWrapperImpl.java:466)
              ... 52 more
      17:18:49,565 INFO  [localhost-startStop-2][HookHotDeployListener:630] Registering hook for kaleo-web
      Loading file:/L:/private/master-bundles/tomcat-7.0.34/temp/0-kaleo-web/WEB-INF/classes/portal.properties
      17:18:49,586 INFO  [localhost-startStop-2][UpgradeProcess:175] Upgrading com.liferay.portal.workflow.kaleo.hook.upgrade.UpgradeProcess_1_0_0
      17:18:49,589 INFO  [localhost-startStop-2][UpgradeProcess:175] Upgrading com.liferay.portal.workflow.kaleo.hook.upgrade.v1_0_0.UpgradeKaleoTaskInstanceToken
      17:18:49,591 INFO  [localhost-startStop-2][UpgradeProcess:175] Upgrading com.liferay.portal.workflow.kaleo.hook.upgrade.UpgradeProcess_1_1_0
      17:18:49,593 INFO  [localhost-startStop-2][UpgradeProcess:175] Upgrading com.liferay.portal.workflow.kaleo.hook.upgrade.v1_1_0.UpgradeWorkflowContext
      SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
      SLF4J: Defaulting to no-operation (NOP) logger implementation
      SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
      17:18:49,641 INFO  [localhost-startStop-2][HookHotDeployListener:757] Hook for kaleo-web is available for use

        Issue Links

          Activity

          Brian Chiu added a comment -

          Working as of:
          Tomcat 7.0.34 + MySQL 5. Portal 6.2.x GIT ID: 4bba78f8abfe2e41b5a045c262f99e3fbb4d2b1f.
          Plugins 6.2.x GIT ID: 327b67ac0a84c2325d067ff4a91fe9526fe13a1a.

          Git Bisect output:

          16f5f2b55cb9fc1061a646f49bef26bb6182c334 is the first bad commit
          commit 16f5f2b55cb9fc1061a646f49bef26bb6182c334
          Author: Michael Han <michael.han@liferay.com>
          Date:   Tue Mar 19 12:43:52 2013 -0500
          
              LPS-33830
          
          :040000 040000 7f53cc834e1cc83c746d4f8ae71f533cbd57be23 cd37fe230fe39acd23dd382e1a947c26ce0e6a03 M      webs
          Brian Chiu added a comment -

          Committed on:
          Plugins 6.1.x EE GIT ID: e1c44852d191c31ceff5e2a3f15756a9c5891439.
          Plugins 6.2.x GIT ID: 34ed20569f791f24c39bd52c29de1258bba47264.

          Brian Chiu added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0.34 + MySQL 5. Portal 6.1.x EE GIT ID: 31176cc27881db65baf786dbe1244776ba557da2.
          Plugins 6.1.x EE GIT ID: e1c44852d191c31ceff5e2a3f15756a9c5891439.
          Tomcat 7.0.34 + MySQL 5. Portal 6.2.x GIT ID: bf30d94109cd625b96498e9a9dc1aec2f8f9ab30.
          Plugins 6.2.x GIT ID: 2f3691cab95ebf0ee37a5f3d24953bf615f1816e.

          Kaleo deploys without incident and the portlets show up in the control panel.


            People

            • Assignee:
              Brian Chiu
              Reporter:
              Brian Chiu
              Recent user:
              Esther Sanz
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 5 weeks, 3 days ago

                Development

                  Structure Helper Panel