Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.30 EE GA3
    • Fix Version/s: 6.1.2 CE GA3, 6.1.30 EE GA3
    • Component/s: WCM
    • Labels:
      None
    • Environment:
      Tomcat 7.0.34 + MySQL 5. Portal 6.1.x EE GIT ID: cdda2d734db0a3cd44f12e38abc4c44c3ae8d12e.
    • Fix Priority:
      5
    • Similar Issues:
      Show 4 results 

      Description

      Steps to reproduce:
      This is 6.1.x EE specific. Does not occur on trunk.

      1. Go to > Control Panel > Web Content
      2. Add Basic Web Content and click Save as Draft
      3. Draft will not be created.
        • If trying to Save as Draft on an already published article, the changes will not be saved.
        • This will also happen in the WCD portlet.

      Expected result:
      Web Content will save.

      Actual result:
      Web Content does not save. No console errors occur.

        Issue Links

          Activity

          Kenji Heigel added a comment -

          Caused by LPS-33804

          Git bisect output:

          
          f6667d5b7fc064e3e7a53fa3491c866fe9e34ac7 is the first bad commit
          commit f6667d5b7fc064e3e7a53fa3491c866fe9e34ac7
          Author: Gergely Mathe <gergely.mathe@liferay.com>
          Date:   Tue Mar 19 13:51:20 2013 +0100
          
              LPS-33804 Web Content creation action is still sent to the server when required general fields are empty
          
          :040000 040000 68ee97d8f49723f765b5a5ac39bbd8d3fc31aead c79cb7b8b973378a150ba2786890d25499bf7dd5 M      portal-web
          
          Gergely Mathe added a comment -

          The fix for this is under review.

          Kenji Heigel added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0.34 + MySQL 5. Portal 6.2.x GIT ID: dda4f5797eddcbe96c0d86a0a9598fa8cf2acb44

          Web Content will be saved as drafts. Checked through CP as well as the WCD portlet.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 15 weeks, 6 days ago

                Development

                  Structure Helper Panel