Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.1 CE GA2, 6.1.20 EE GA2
    • Component/s: Web Services
    • Labels:
    • Environment:
      LIFERAY VERSION: 6.1 GA2
      OPERATING SYSTEM: Red Hat Enterprise 6
      APPLICATION SERVER: Other
      JAVA VIRTUAL MACHINE: Java 6
      DATABASE: Oracle 11.1
    • Branch Version/s:
      6.1.x
    • Backported to Branch:
      Committed
    • Similar Issues:
      Show 5 results 

      Description

      I've faced an issue on accessing custom and/or not built-in web services in case of using Weblogic v10.3.6 with Liferay 6.1 GA2
      The web services are working fine with Tomcat.

      Steps to reproduce:
      1) Have a Liferay 6.1.20 EE installed on Weblogic Server 10.3.6
      2) Deploy the an external plugin which has remote services e.g.: "kaleo-web-6.1.20.1-ee-ga2-20120731110418084.war"
      3) Try to get the list of the plugin's web services (http://test.dev:7001/kaleo-web/api/axis)

      ------------------------------------------------
      http://test.dev:7001/kaleo-web/api/axis

      Observed behavior: If you navigate to the above URL, you'll get the following in the browser:
      "And now... Some Services
      AXIS error
      Sorry, something seems to have gone wrong... here are the details:
      Exception - java.lang.NullPointerException"
      ------------------------------------------------

      In case of using Tomcat everything is working as expected:
      http://test.dev:8080/kaleo-web/api/axis

      And now... Some Services
      Plugin_Kaleo_KaleoDefinitionService (wsdl)

      getKaleoDefinitions
      getKaleoDefinitions
      ------------------------------------------------

      1. AxisEngine.java
        17 kB
        Igor Spasic
      2. JavaServiceDesc.java
        55 kB
        Igor Spasic

        Activity

        Igor Spasic added a comment -

        Uh, finally confirmed the same thing happens on trunk (6.x)

        Sophia Zhang added a comment - - edited

        PASSED Manual Testing following the steps in the description.

        Fixed on:
        Weblogic 10.3.6 + MySQL 5. Portal 6.1.x EE GIT ID: 2a6d1879ddefc0a27ced859f60d5f169ac4d62dd.
        Plugins 6.1.x EE GIT ID: a5d5f69c902d196351ad213b57065433aba6b612.
        Weblogic 10.3.6 + MySQL 5. Portal 6.2.x GIT ID: c3188f91803710f0bcf2440165ab198ca85332f7.
        Plugins 6.2.x EE GIT ID: 829b720bf602238887b331ed3afe589d3c6ce5ca.

        When access http://test.dev:8080/kaleo-web/api/axis, it shows the following on the page:

        And now... Some Services
        Plugin_Kaleo_KaleoDefinitionService (wsdl)

        getKaleoDefinitions
        getKaleoDefinitions


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 20 weeks, 2 days ago

              Development

                Subcomponents

                  Structure Helper Panel