PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-34310

Can't install private plugin form version 6.1.1.9 to 6.1.1.10: version is newer than version

    Details

    • Similar Issues:
      Show 5 results 

      Description

      Try to upgrade a plugin version from private plugin installer from version 6.1.1.9 to 6.1.1.10 doesn't work.
      Liferay trace:
      Not updating ..... because version 6.1.1.9-SNAPSHOT is newer than version 6.1.1.10-SNAPSHOT

        Issue Links

          Activity

          Hide
          Aniceto P Madrid added a comment -

          Riccardo
          It's a bit difficult to judge with such information. Where is shown that message? Can you include the stack trace or the log and not only a contextless text? Which is the value of the module-incremental-version property?
          Thanks

          Show
          Aniceto P Madrid added a comment - Riccardo It's a bit difficult to judge with such information. Where is shown that message? Can you include the stack trace or the log and not only a contextless text? Which is the value of the module-incremental-version property? Thanks
          Hide
          Riccardo Martini added a comment -

          Auto deployment log

          Show
          Riccardo Martini added a comment - Auto deployment log
          Hide
          Riccardo Martini added a comment -

          Aniceto,
          we are building our liferay portlet plugin with maven by a liferay portlet artifact.
          We define the version in the pom.xml file with <version>6.1.1.xxx-SNAPSHOT</version> tag. In every release update , we set the value of "module-incremental-version" in "liferay-plugin-package.properties" according to the xxx minor number.
          From version 1 to 9 it was working correctly.
          Passing from release 9 to 10 we get the warning and redeploy fails.
          It's seems an alphabetical comparator problem

          Thanks

          Show
          Riccardo Martini added a comment - Aniceto, we are building our liferay portlet plugin with maven by a liferay portlet artifact. We define the version in the pom.xml file with <version>6.1.1.xxx-SNAPSHOT</version> tag. In every release update , we set the value of "module-incremental-version" in "liferay-plugin-package.properties" according to the xxx minor number. From version 1 to 9 it was working correctly. Passing from release 9 to 10 we get the warning and redeploy fails. It's seems an alphabetical comparator problem Thanks
          Hide
          Edward Gonzales added a comment -

          Hello everyone! We are in the process of removing component "Portlet" from LPS. Please make the necessary adjustments to affected filters. Thanks!

          Show
          Edward Gonzales added a comment - Hello everyone! We are in the process of removing component "Portlet" from LPS. Please make the necessary adjustments to affected filters. Thanks!
          Hide
          Aniceto P Madrid added a comment -

          Riccardo

          Hace you tried to update from 009 a 010?

          Show
          Aniceto P Madrid added a comment - Riccardo Hace you tried to update from 009 a 010?
          Hide
          Aniceto P Madrid added a comment -

          This issue is due to the usual sort of strings. If more than nine updated may happen, then use two digits for version instead of only one. The submitter has not responded within 10 days.  This issue can be closed

          Show
          Aniceto P Madrid added a comment - This issue is due to the usual sort of strings. If more than nine updated may happen, then use two digits for version instead of only one. The submitter has not responded within 10 days.  This issue can be closed

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 45 weeks, 4 days ago

                Development

                  Structure Helper Panel