PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-34545

DDL - Clicking on HTML text area preview leads to a blank "dialog[aui_#####]" error page in Internet Explorer and Firefox

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE M5
    • Fix Version/s: 6.2.0 CE B1
    • Component/s: Dynamic Data Lists
    • Labels:
      None
    • Environment:
      Tomcat 7.0.34 + MySQL 5. IE 9.0.8. Portal 6.2.x GIT ID: b309722201e908a0fc6d7eef3f6a77fda6f5c504.
      Tomcat 7.0.34 + MySQL 5. Firefox 20.0.1. Portal 6.2.x GIT ID: b309722201e908a0fc6d7eef3f6a77fda6f5c504.
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      This happens on Internet Explorer 9 and Firefox 20. This does NOT happen on Google Chrome 26.

      In firefox, the preview will appear for a split second, then the browser will take you to the blank page.

      Steps to reproduce:

      1. Navigate to Control Panel > Dynamic Data Lists
      2. Add a data definition with an HTML field
      3. Add a list and enter a record that uses the HTML field
      4. Click on the (Preview) link for HTML

      Expected result:
      The preview of the HTML displays (See the Chrome screenshot)

      Actual result:
      The page reloads to a blank page with "dialogaui_####"

      1. Capture.PNG
        32 kB
      2. Chrome.PNG
        41 kB
      3. Fixed-firefox.jpg
        73 kB
      4. Fixed-ie.jpg
        56 kB

        Issue Links

          Activity

          Brian Chiu added a comment -

          Reproduced on:
          Tomcat 7.0.34 + MySQL 5. IE 9.0.8. Portal 6.2.x GIT ID: b309722201e908a0fc6d7eef3f6a77fda6f5c504.
          Tomcat 7.0.34 + MySQL 5. Firefox 20.0.1. Portal 6.2.x GIT ID: b309722201e908a0fc6d7eef3f6a77fda6f5c504.

          The same issue occurs. Clicking on the text area leads to a blank page with some aui_#### text.

          Brian Chiu added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomact 7.0.40 + MySQL 5. IE 9.0.8. Portal 6.2.x GIT ID: 7db0dccf7d7890a9eed7850a87ddd98e44e44334.
          Tomact 7.0.40 + MySQL 5. Firefox 22.0. Portal 6.2.x GIT ID: 7db0dccf7d7890a9eed7850a87ddd98e44e44334.

          I can view previews now in both internet explorer and in firefox. I've attached screenshots of this.


            People

            • Assignee:
              Brian Chiu
              Reporter:
              Brian Chiu
              Recent user:
              Randy Zhu
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 1 day ago

                Development

                  Structure Helper Panel