Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Duplicate
    • Affects Version/s: 5.2.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Win XP, liferay 5.2.3, solr 1.3.0, solr-web 5.2.0.1, tomcat 6.0.18
    • Similar Issues:
      Show 5 results 

      Description

      When trying to search the portal with search plugin, solr throws a NullPointerException.

      14:16:17,528 ERROR [SolrReaderMessageListener:47] Unable to process message {destination=liferay/search_reader, responseDestination=liferay/search_reader/response, responseId=edd1
      a4b-ebe9-45c0-8e6d-a5666b2d232d, payload=

      {command=SEARCH, companyId=1, id=null, doc=null, query=+(+portletId:36) +(title:test content:test tagsEntries:test), sorts=[Lcom.liferay.p rtal.kernel.search.Sort;@9d509b, start=0, end=5}

      , values=null}
      com.liferay.portal.kernel.search.SearchException: java.lang.NullPointerException
      at com.liferay.portal.search.solr.SolrIndexSearcherImpl.search(SolrIndexSearcherImpl.java:99)
      at com.liferay.portal.search.solr.SolrSearchEngineUtil.search(SolrSearchEngineUtil.java:79)
      at com.liferay.portal.search.solr.messaging.SolrReaderMessageListener.doCommandSearch(SolrReaderMessageListener.java:86)
      at com.liferay.portal.search.solr.messaging.SolrReaderMessageListener.doReceive(SolrReaderMessageListener.java:68)
      at com.liferay.portal.search.solr.messaging.SolrReaderMessageListener.receive(SolrReaderMessageListener.java:44)
      at com.liferay.portal.kernel.messaging.InvokerMessageListener.receive(InvokerMessageListener.java:70)
      at com.liferay.portal.kernel.messaging.ParallelDestination$1.run(ParallelDestination.java:60)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: java.lang.NullPointerException
      at org.apache.solr.client.solrj.SolrQuery.toSortString(SolrQuery.java:497)
      at org.apache.solr.client.solrj.SolrQuery.addSortField(SolrQuery.java:293)
      at com.liferay.portal.search.solr.SolrIndexSearcherImpl.search(SolrIndexSearcherImpl.java:88)
      ... 9 more

        Activity

        Tobias Rübner added a comment - - Restricted to
        Bruno Farache added a comment -

        duplicates LPS-2885


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              6 years, 8 weeks, 2 days ago

              Development

                Structure Helper Panel