Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-35826

Can't install plugin form version 9 to 10: version 9 is newer than version 10.

    Details

      Description

      We set 'module-incremental-version' to mark the version of the plugin. Currently, we have deployed version 9. After the value of 'module-incremental-version' increasing to 10, the plugin can not be deployed any more. Also, there will be message showing 'Not updating *** because version 6.1.20.9 is newer than version 6.1.20.10'.

      Steps:
      1. Change the value of 'module-incremental-version' in liferay-plugin-package.properties to 9.
      2. Deploy the plugin. The plugin can be deployed properly.
      3. Make a copy of the plugin and change the value of 'module-incremental-version' to 10.
      4. Deploy the plugin.
      The plugin can not be deployed. Also, there will be message showing 'Not updating *** because version 6.1.20.9 is newer than version 6.1.20.10'.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              pani.gui Pani Gui (Inactive)
              Reporter:
              emma.liu Emma Liu
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                8 years, 20 weeks, 3 days ago

                  Packages

                  Version Package
                  6.1.30 EE GA3
                  6.2.0 CE M6