PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-36067

Child page selection is not updated after Parent page is selected for Publishing

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.1 CE GA2, 6.1.20 EE GA2
    • Component/s: UI Infrastructure
    • Labels:
    • Environment:
      Portal 6.1.x EE.GIT ID: 8ab18eb354a1540fbd021f8958743980a88ea705
      Portal 6.2.x CE GIT ID: 05807764c7f053c9503bcc6c8e68177bb969522f
    • Branch Version/s:
      6.1.x, 6.0.x
    • Backported to Branch:
      Committed
    • Epic/Theme:
    • Story Points:
      6
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Steps to Reproduce:

      1. Turn Staging on in Site Settings
      2. Got to Site Pages in Control Panel
      3. Create a page P1
      4. Create a child page called C1
      5. Click on the Staging down arrow and select Publish to Live Now
      6. Notice no pages are listed
      7. Click on Change > Select Pages
      8. Check page P1 (C1 is selected by default as well)
      9. Uncheck page C1
      10. Click Select
      11. P1 is selected for publication
      12. Click Change Selection again
      13. Both P1 and C1 are checked (C1 should not be selected)
      14. Click Select

      Expected Result: Both P1 and C1 should be listed
      Actual Result: Only P1 is listed

        Issue Links

          Activity

          Ginson Ren added a comment - - edited

          PASSED Manual Testing following the steps in the description.

          Reproduced on:
          Tomcat 7.0 + MySQL 5. Portal 6.1.20 EE GA2.

          Click Change Selection again, both P1 and C1 are checked, then click Select, only P1 is listed.

          Fixed on:
          Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 7aa2e9c4c1b9dbfe8cd68de592f0312a8ce68c07.

          Click Change Selection again, only P1 was checked, then check C1 and click Select, both P1 and C1 are listed.

          Ginson Ren added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0 + MySQL 5. Portal 6.1.x EE GIT ID: b7260fd3698066fcefb9ea56cb55045e2475b906.

          Click Change Selection again, only P1 was checked, then check C1 and click Select, both P1 and C1 are listed.

          Ginson Ren added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 6.0 + MySQL 5. Portal 6.0.x GIT ID: d9e5211c4d79bde8a7ce266c6189c2d776012088.
          Tomcat 7.0 + MySQL 5. Portal 6.1.30 EE GIT ID: b59734f18dfa034d521a91df0a857417a6f73adc.

          Click Change Selection again, only P1 was checked, then check C1 and click Select, both P1 and C1 are listed.


            People

            • Assignee:
              Ginson Ren
              Reporter:
              Andrew Betts
              Recent user:
              Jose Jimenez
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 36 weeks ago

                Development

                  Structure Helper Panel