Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-36080

Resiliency Workflow and Workflow Configuration SPI removes Workflow Engine

    Details

    • Fix Priority:
      5

      Description

      When navigating to control panel > workflow, workflow options do not exist and is replaced by text "No workflow engine is deployed".

      These are the steps to reproduce:
      1. Deploy kaleo and resilience plugins
      2. Navigate to Control Panel > workflow
      3. Assert single approver (see attached)
      4. Setup SPI 8081 for workflow
      5. Navigate to Control Panel > workflow
      6. Assert message No workflow engine deployed (see attached)

      Expected Result: Workflow menu
      Actual Result: Message no workflow engine deployed

      No exceptions are thrown. When user destroys SPI, portal is able to recognize workflow engine and functionality is enabled.

      *Note same error occurs when SPI is attached with workflow configuration component as well.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                john.co John Co
                Reporter:
                john.co John Co
                Participants of an Issue:
                Recent user:
                Esther Sanz
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  6 years, 19 weeks, 5 days ago

                  Packages

                  Version Package
                  6.2.0 CE M6