Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-36727

Buttons in Jasper Reports do not work when adding a report definition

    Details

      Description

      Steps to reproduce:
      Method 1

      1. Deploy jasper-reports-web and reports-portlet
      2. Admin > Site Administration > Reports Admin
      3. Click on the Definitions tab
      4. Click Add Report Definition
      5. For the Key and Value fields under Report Parameters, use: test
      6. Click the green add button

      Method 2

      1. Deploy jasper-reports-web and reports-portlet
      2. Admin > Site Administration > Reports Admin
      3. Click on the Definitions tab
      4. Click Add Report Definition
      5. Upload a template (.jrxml file)
      6. Save the definition
      7. Edit the same definition
      8. Click the minus button next to the template name

      Expected results
      The add button should add the parameter. The remove button should remove the template.

      Actual results:
      The add button does not add the parameter. The remove button does not remove the template. A firebug error also occurs on the page.

      Firebug error:

      AUI().one(".report-parameters") is null
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kenji.heigel Kenji Heigel
              Reporter:
              kenji.heigel Kenji Heigel
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                8 years, 8 weeks, 5 days ago

                  Packages

                  Version Package
                  6.2.0 CE B1