Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-37285

Image with EXIF metadata will not display in documents and media portlet

    Details

    • Type: Regression Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 6.1.30 EE GA3
    • Fix Version/s: 6.1.30 EE GA3
    • Component/s: Documents & Media
    • Labels:
      None
    • Environment:
      Tomcat 7 + MySQL 5. Portal 6.1.x GIT ID: f4cc8557d4c19c0ffbbc2237afe570833f954a33.

      Description

      Prerequisite: Make sure ImageMagick is installed and enabled through External Services in Site Administration.
      1. Create a page called "documents and media test" and add the Documents and Media portlet.
      2. Click on Add -> basic document and upload a picture with exif metadata properties.
      3. Verify that the picture can be previewed.

      Expected result:
      User can view the image preview.

      Actual result:
      User is stuck on the generating preview will take a few minutes screen.

        Attachments

          Activity

            People

            • Assignee:
              julian.hsu Julian Hsu (Inactive)
              Reporter:
              julian.hsu Julian Hsu (Inactive)
              Participants of an Issue:
              Recent user:
              Esther Sanz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                7 years, 7 weeks ago

                Packages

                Version Package
                6.1.30 EE GA3