PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-3796

Failed to bring up /web/guest page with java.lang.NoClassDefFoundError: Could not initialize class org.portletbridge.portlet.DefaultIdGenerator error

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 5.2.3
    • Fix Version/s: --Sprint 12/11
    • Component/s: Bookmarks
    • Labels:
      None
    • Environment:
      fedora 11
    • Liferay Contributor's Agreement:
      Accept
    • Similar Issues:
      Show 5 results 

      Description

      I just installed liferay 5.2.3 SE on a new fedora 11 installed box. When I tried to start up liferay 5.2.3, the default page, http://localhost:8080, did not come up. When I tied to access it from the firefox browser, I got the following error:

      INFO: Server startup in 119512 ms
      17:39:38,366 WARN [PortalImpl:2948] Current URL /web/guest generates exception:

      {groupId=16,privateLayout=false}

      does not have any layouts
      Starting Liferay Portal Standard Edition 5.2.3 (Augustine / Build 5203 / May 20, 2009)
      17:39:38,902 INFO [DBUtil:498] Database supports case sensitive queries
      17:39:43,367 ERROR [OpenSSOFilter:139] javax.servlet.ServletException: Servlet.init() for servlet Main Servlet threw exception
      javax.servlet.ServletException: Servlet.init() for servlet Main Servlet threw exception
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1213)
      at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:808)
      at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:599)
      at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:436)
      at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:374)
      at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:302)
      at com.liferay.portal.util.PortalImpl.sendError(PortalImpl.java:3010)
      at com.liferay.portal.util.PortalUtil.sendError(PortalUtil.java:919)
      at com.liferay.portal.servlet.FriendlyURLServlet.service(FriendlyURLServlet.java:119)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.servlet.filters.strip.StripFilter.processFilter(StripFilter.java:142)
      at com.liferay.portal.kernel.servlet.BaseFilter.doFilter(BaseFilter.java:91)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.kernel.servlet.BaseFilter.doFilter(BaseFilter.java:94)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.servlet.filters.gzip.GZipFilter.processFilter(GZipFilter.java:140)
      at com.liferay.portal.kernel.servlet.BaseFilter.doFilter(BaseFilter.java:91)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.servlet.filters.secure.SecureFilter.processFilter(SecureFilter.java:282)
      at com.liferay.portal.kernel.servlet.BaseFilter.doFilter(BaseFilter.java:91)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.servlet.filters.cache.CacheFilter.processFilter(CacheFilter.java:368)
      at com.liferay.portal.kernel.servlet.BaseFilter.doFilter(BaseFilter.java:91)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.servlet.filters.autologin.AutoLoginFilter.processFilter(AutoLoginFilter.java:257)
      at com.liferay.portal.kernel.servlet.BaseFilter.doFilter(BaseFilter.java:91)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.servlet.filters.sso.opensso.OpenSSOFilter.processFilter(OpenSSOFilter.java:73)
      at com.liferay.portal.kernel.servlet.BaseFilter.doFilter(BaseFilter.java:91)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.sharepoint.SharepointFilter.processFilter(SharepointFilter.java:193)
      at com.liferay.portal.kernel.servlet.BaseFilter.doFilter(BaseFilter.java:91)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.servlet.filters.virtualhost.VirtualHostFilter.doFilter(VirtualHostFilter.java:191)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.servlet.filters.threadlocalcache.ThreadLocalCacheFilter.processFilter(ThreadLocalCacheFilter.java:55)
      at com.liferay.portal.kernel.servlet.BaseFilter.doFilter(BaseFilter.java:91)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.BaseFilter.processFilter(BaseFilter.java:154)
      at com.liferay.portal.kernel.servlet.BaseFilter.doFilter(BaseFilter.java:94)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.tuckey.web.filters.urlrewrite.UrlRewriteFilter.doFilter(UrlRewriteFilter.java:738)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
      at java.lang.Thread.run(Thread.java:636)
      Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.portletbridge.portlet.DefaultIdGenerator
      at org.portletbridge.portlet.PortletBridgePortlet.createViewPortlet(PortletBridgePortlet.java:219)
      at org.portletbridge.portlet.PortletBridgePortlet.init(PortletBridgePortlet.java:73)
      at com.liferay.portlet.webproxy.WebProxyPortlet.init(WebProxyPortlet.java:57)
      at javax.portlet.GenericPortlet.init(GenericPortlet.java:107)
      at com.liferay.portlet.InvokerPortletImpl.init(InvokerPortletImpl.java:250)
      at com.liferay.portlet.PortletInstanceFactoryImpl.init(PortletInstanceFactoryImpl.java:245)
      at com.liferay.portlet.PortletInstanceFactoryImpl.init(PortletInstanceFactoryImpl.java:217)
      at com.liferay.portlet.PortletInstanceFactoryImpl.create(PortletInstanceFactoryImpl.java:140)
      at com.liferay.portlet.PortletInstanceFactoryUtil.create(PortletInstanceFactoryUtil.java:47)
      at com.liferay.portal.servlet.MainServlet.init(MainServlet.java:231)
      at javax.servlet.GenericServlet.init(GenericServlet.java:212)
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1172)
      ... 81 more

        Activity

        Dale Shan added a comment - - Restricted to

        I can not duplicate your issue with liferay tomcat 5 bundle and tomcat 6 bundle.
        Now i will close it, if you still has issue please reopen it.
        Thanks

        Pierluigi Riti added a comment -

        I have same error on Fedora 11

        Dale Shan added a comment - - Restricted to

        Hi,

        Are you using a Liferay bundle or manual deployment?

        Pierluigi Riti added a comment -

        hi using liferay bundle

        Tony Bolger added a comment - - Restricted to

        I had the same stacktrace.

        The real exception is swallowed in the Tomcat 6 version - any issue initializing the DefaultIDGenerator class gets mis-reported as a missing class. Luckily the tomcat 5.5 bundle prints both the real exception and this incorrect one.

        java.lang.ExceptionInInitializerError
        at org.portletbridge.portlet.PortletBridgePortlet.createViewPortlet(PortletBridgePortlet.java:219)

        <trim lots of irrelevant stuff>

        org.portletbridge.portlet.GUIDException: error - failure to instantiate GUIDGeneratorjava.net.UnknownHostException: myhost.mydomain: myhost.mydomain
        at org.portletbridge.portlet.GUIDGenerator.<init>(GUIDGenerator.java:144)
        at org.portletbridge.portlet.DefaultIdGenerator.<init>(DefaultIdGenerator.java:43)
        at org.portletbridge.portlet.DefaultIdGenerator.<clinit>(DefaultIdGenerator.java:29)
        at org.portletbridge.portlet.PortletBridgePortlet.createViewPortlet(PortletBridgePortlet.java:219)
        at org.portletbridge.portlet.PortletBridgePortlet.init(PortletBridgePortlet.java:73)

        Followed by:

        java.lang.NoClassDefFoundError: Could not initialize class org.portletbridge.portlet.DefaultIdGenerator
        at org.portletbridge.portlet.PortletBridgeServlet.init(PortletBridgeServlet.java:103)

        As you can see from the first bit, the DefaultIdGenerator class certainly was found.

        For me, the problem was the lack of a valid DNS or /etc/hosts entry for the hostname, and with that, both the tomcat 5.5 and tomcat 6.0 versions started up ok.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              5 years, 39 weeks, 3 days ago

              Development

                Structure Helper Panel