Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-38634

After changing language user sign in is not redirected to https when company.security.auth.requires.https=true

    Details

      Description

      STEPS TO REPRODUCE

      1. In server.xml make sure you are using port 80 for http and pot 443 for https
      2. Setup tomcat for ssl (see http://www.liferay.com/group/customer/kbase/-/knowledge_base/article/14406628)
      3. Set the following in portal-ext:

        com.liferay.portal.servlet.filters.sessionid.SessionIdFilter=true
        session.enable.phishing.protection=false
        company.security.auth.requires.https=true

      4. Start liferay. Go to https://localhost:443
      5. As admin, add a language portlet to homepage
      6. Sign out and clear browser cache
      7. Switch to http
      8. Change language
      9. Click sign in link on the top right

      Result: login page is in http, not https

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                lu.liu Lu Liu
                Reporter:
                preston.crary Preston Crary
                Participants of an Issue:
                Recent user:
                Esther Sanz
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  5 years, 50 weeks, 5 days ago

                  Packages

                  Version Package
                  6.1.X EE
                  6.2.0 CE RC1