PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-39080

Add Page with "Hide from Navigation Menu" from + doesn't hide the page from Navigation, we need to refresh the page to be able to see it as hidden

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE B1, 6.2.0 CE B2
    • Fix Version/s: 6.2.0 CE RC5
    • Component/s: UI Infrastructure
    • Labels:
    • Environment:
      Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 6fbc567faee807fca1ba392c41c1446537cfdf1a.
    • Story Points:
      3
    • Fix Priority:
      3
    • Similar Issues:
      Show 5 results 

      Description

      While creating a new page from if we select "Hide from Navigation Menu" it is not hiding the page from Navigation at the same time. And we need to refresh the page in order to remove it from Navigation. As we've Page name appearing in Navigation while we typing it in Page name field, I think it would be better if "Hide from Navigation Menu" will work accordingly to make it more consistent.

        Activity

        Koor Gai added a comment -

        Hi Tejas,

        Thank you for finding and reporting this issue! I was able to reproduce it at 6.2.x HEAD on window 7 and Tomcat, with a MySQL db. Thus, I will update the ticket to reflect the issue.

        Iliyan Peychev added a comment -

        Just started reviewing :)

        Sent from GH.

        Ginson Ren added a comment -

        PASSED Manual Testing following the steps in the description.

        Reproduced on:
        Tomcat 7.0 + MySQL 5. Portal master GIT ID: 91cd3eec6491e479415430814a88d1e90c288d43.

        User need to refresh the page to be able to see the page as hidden which added with "Hide from Navigation Menu".

        Fixed on:
        Tomcat 7.0 + MySQL 5. Portal master GIT ID: 1fab390b1697dd80d76ea0af4de7e148e3cc6d31.

        User don't need to refresh the page to be able to see the page as hidden which added with "Hide from Navigation Menu".


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 27 weeks, 2 days ago

              Development

                Structure Helper Panel