Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-39239

Web content preview from edit page always displays default locale in template variable

    Details

      Description

      1. Go to Control Panel > Web Content
      2. Create a simple structure with any field
      3. Create a template for the structure, set Velocity for the language
      4. Add the following to the body of the template: <h1> $locale </h1>
      5. Create a web content from the new structure, add any title and save as draft
      6. Add a translation for the web content with any language, and publish it
      7. Change your display language to the one for which you created the translation
      8. Open the web content for editing again and click on Preview

      Result: in the preview, the default locale will be displayed, and not the current locale

      Note: this is not an issue on trunk, but this feature has been (and is being) refactored on trunk for 6.2.0, so we should fix this on 6.1.x

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              linda.sui Linda Sui
              Reporter:
              gergely.mathe Gergely Mathe (Inactive)
              Participants of an Issue:
              Recent user:
              Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                8 years, 16 weeks, 1 day ago

                  Packages

                  Version Package
                  6.1.X EE