Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-39629

LDAP credentials not saved in database first time. Cannot login anymore afterwards

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Inactive
    • Affects Version/s: 6.1.1 CE GA2, 6.1.2 CE GA3
    • Fix Version/s: 7.0.0 M6
    • Component/s: Portal Configuration
    • Labels:
      None
    • Environment:
      linux

      Description

      Start a server with one LDAP configured: (I removed the values)

      ldap.server.ids=0
      ldap.server.name.0=
      ldap.base.provider.url.0=
      ldap.base.dn.0=dc=pvda,dc=
      ldap.security.principal.0=
      ldap.security.credentials.0=

      etc ...

      Then go to portal administration, authentication settings, ldap. And edit the LDAP configuration. Do nothing, just save the form.

      Result:

      select * from mijnpvda.PortalPreferences p where p.preferences like '%ldap%';
      

      Credentials (ldap.security.credentials) was not saved.

      Probably has something to due due to the fact that the postfix 0 is changed to another number.

        Attachments

          Activity

            People

            Assignee:
            michael.saechang Michael Saechang
            Reporter:
            kdejaeger Koen De Jaeger (Inactive)
            Participants of an Issue:
            Recent user:
            Esther Sanz
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              8 years, 21 weeks, 3 days ago

                Packages

                Version Package
                7.0.0 M6