PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-39802

Calendar exports all events, regardless of the status in which they are. For example: Calendar exports events with status "IN_TRASH", when should export only events with status "MAYBE", "APPROVED" and "PENDING".

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE RC1
    • Fix Version/s: 6.2.0 CE RC1
    • Component/s: Calendar
    • Labels:
    • Fix Priority:
      3
    • Similar Issues:
      Show 5 results 

      Description

      These are the steps to reproduce:

      1. Deploy Calendar
      2. Add Calendar
      3. Click Add Event
      4. After the event has been added, click on the event to edit it
      5 Click Delete and confirm
      5. Export the calendar
      6. Open the generated file

      Expected Result:
      Only events with status "MAYBE", "APPROVED" or "PENDING" should appear in the
      file.
      The deleted event should not appear in the file.

      Actual Result:
      All events, regardless of the status, appear in the file.

        Activity

        Albert Lee added a comment -

        PASSED Manual Testing following the steps in the description.

        Fixed on:
        Tomcat 7.0 + MySQL 5. Portal master GIT ID: 8cbad49fb75d428f55e16202dcf52e4cde038bc0.
        Plugins master GIT ID: b691e25c00b362996af12e92f710f1a409b6b73e.

        Created several events, approved, maybe, deleted those events and exported the calendar. There are no events listed in the ics file.


          People

          • Assignee:
            Albert Lee
            Reporter:
            Miguel Angelo
            Recent user:
            Randy Zhu
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 26 weeks, 4 days ago

              Development

                Structure Helper Panel