Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE RC1, 6.2.0 CE RC2
    • Fix Version/s: 6.2.0 CE RC2
    • Component/s: Calendar
    • Labels:
      None
    • Environment:
      Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 34080ddff849c33d7ef0d0e2cea4bba264d11d1f.
      Plugins 6.2.x GIT ID: 9756336da19d2e585c1b2c03903a1d8cc30f60c5.
    • Fix Priority:
      5
    • Similar Issues:
      Show 5 results 

      Description

      1. Add the following to your portal-ext.properties:
        pop.server.notifications.enabled=true
        pop.server.notifications.interval=1
        pop.server.subdomain=
      2. Deploy the Calendar Portlet
      3. Configure the Mail POP/SMTP Servers
      4. Change the Portal Instance's mail domain
      5. Add a user w/ a real email address
      6. Add the Calendar Portlet
      7. Login as the new user
      8. Add a Calendar Event in the future w/ an Email Notification a couple minutes away from the current time

      Expected Results:
      Once the time for the notification is reached an email should be sent.

      Actual Results:
      No email notification is sent.
      The following exception is thrown:

      22:54:14,026 ERROR [liferay/scheduler_dispatch-5][ParallelDestination:92] Unable to process message {destinationName=liferay/scheduler_dispatch, response=null, responseDestinationName=null, responseId=null, payload=null, values={JOB_NAME=com.liferay.calendar.messaging.CheckBookingsMessageListener, EXCEPTIONS_MAX_SIZE=0, GROUP_NAME=com.liferay.calendar.messaging.CheckBookingsMessageListener, DESTINATION_NAME=liferay/scheduler_dispatch, PORTLET_ID=1_WAR_calendarportlet, JOB_STATE=com.liferay.portal.kernel.scheduler.JobState@4ca6fef6, companyId=0, MESSAGE_LISTENER_CLASS_NAME=com.liferay.calendar.messaging.CheckBookingsMessageListener, RECEIVER_KEY=com.liferay.calendar.messaging.CheckBookingsMessageListener.com.liferay.calendar.messaging.CheckBookingsMessageListener, MESSAGE_LISTENER_UUID=043bad5e-0f8d-45b8-9005-63a939736e82}}
      com.liferay.portal.kernel.messaging.MessageListenerException: com.liferay.portal.kernel.exception.SystemException: java.lang.IllegalArgumentException: Invalid value
              at com.liferay.portal.kernel.messaging.BaseMessageListener.receive(BaseMessageListener.java:32)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
              at java.lang.reflect.Method.invoke(Unknown Source)
              at com.liferay.portal.kernel.bean.ClassLoaderBeanHandler.invoke(ClassLoaderBeanHandler.java:67)
              at com.sun.proxy.$Proxy782.receive(Unknown Source)
              at com.liferay.portal.kernel.scheduler.messaging.SchedulerEventMessageListenerWrapper.receive(SchedulerEventMessageListenerWrapper.java:76)
              at com.liferay.portal.kernel.messaging.InvokerMessageListener.receive(InvokerMessageListener.java:72)
              at com.liferay.portal.kernel.messaging.ParallelDestination$1.run(ParallelDestination.java:69)
              at com.liferay.portal.kernel.concurrent.ThreadPoolExecutor$WorkerTask._runTask(ThreadPoolExecutor.java:682)
              at com.liferay.portal.kernel.concurrent.ThreadPoolExecutor$WorkerTask.run(ThreadPoolExecutor.java:593)
              at java.lang.Thread.run(Unknown Source)
      Caused by: com.liferay.portal.kernel.exception.SystemException: java.lang.IllegalArgumentException: Invalid value
              at com.liferay.calendar.service.impl.CalendarBookingLocalServiceImpl.checkCalendarBookings(CalendarBookingLocalServiceImpl.java:223)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
              at java.lang.reflect.Method.invoke(Unknown Source)
              at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:115)
              at com.liferay.portal.spring.transaction.DefaultTransactionExecutor.execute(DefaultTransactionExecutor.java:62)
              at com.liferay.portal.spring.transaction.TransactionInterceptor.invoke(TransactionInterceptor.java:51)
              at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:111)
              at com.liferay.portal.spring.aop.ServiceBeanAopProxy.invoke(ServiceBeanAopProxy.java:175)
              at com.liferay.portal.security.pacl.PACLInvocationHandler.doInvoke(PACLInvocationHandler.java:62)
              at com.liferay.portal.security.pacl.PACLInvocationHandler.invoke(PACLInvocationHandler.java:51)
              at com.sun.proxy.$Proxy758.checkCalendarBookings(Unknown Source)
              at com.liferay.calendar.service.CalendarBookingLocalServiceUtil.checkCalendarBookings(CalendarBookingLocalServiceUtil.java:364)
              at com.liferay.calendar.messaging.CheckBookingsMessageListener.doReceive(CheckBookingsMessageListener.java:29)
              at com.liferay.portal.kernel.messaging.BaseMessageListener.receive(BaseMessageListener.java:26)
              ... 12 more
      Caused by: java.lang.IllegalArgumentException: Invalid value
              at com.liferay.calendar.notification.NotificationType.parse(NotificationType.java:29)
              at com.liferay.calendar.model.impl.CalendarBookingImpl.getFirstReminderNotificationType(CalendarBookingImpl.java:68)
              at com.liferay.calendar.util.NotificationUtil.notifyCalendarBookingReminders(NotificationUtil.java:185)
              at com.liferay.calendar.service.impl.CalendarBookingLocalServiceImpl.checkCalendarBookings(CalendarBookingLocalServiceImpl.java:213)
              ... 27 more

      For more context of the Exception please see attached file.

        Activity

        mandy.zia added a comment -

        Reproduced using Glassfish 3.1 + DB2 10.1 + Solaris 11 EX + Internet Explorer 10.

        Joseph Chin added a comment - - edited

        Reproduced using JBoss EAP 6 + PostgreSQL 9.2.4 + Windows Server 2008 + Internet Explorer 9.

        Michael Hashimoto added a comment -

        No Longer Reproducible on:
        Tomcat 7.0 + MySQL 5. Portal master GIT ID: 5c2ebf7c4f9b5b1a2fbdf0c8b476cecb5b00ae2e.
        Plugins master GIT ID: 6bdd4d81b1fc9c4d8144922d26262629fe2b4217.

        The email notification is sent to the user as expected.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 44 weeks, 2 days ago

              Development

                Structure Helper Panel