Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE RC2
    • Fix Version/s: 7.0.0 M1
    • Component/s: Calendar
    • Labels:
      None
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Editing repeated events does lose track of the exception days.

      Steps to reproduce

      1. Create an event at the first day of the week which repeats for five dayhs
      2. Drag the third day instance to a bit earlier time
      3. Click on "Only this instance"
      4. Drag the first instance of the repeating events to a bit later time.
      5. Choose "All events in the series"

      Expected results

      • At step 4, the earlier instance will stay unaffected
      • At step 4, the four remaining instances will move to the new time

      Actual results

      • At step 4, both the earlier instance stays unaffected the four remaining instances move to the new time. However, a new instance appears between the second and the third ones.

        Activity

        Eduardo Lundgren added a comment -

        Just started reviewing :)

        Sent from GH.

        Esther Sanz added a comment -

        Resolved as it is already committed

        Justin Choi added a comment -

        PASSED Manual Testing following the steps in the description.

        Fixed on:
        Tomcat 7.0.42 + MySQL 5. Portal master GIT ID: faed9af979ce11265a3014425c96a5d0adb8dd6c. Plugins master GIT ID: acdeddff2940dd45fd05ef07e73fbddb82070226.

        • Have to deploy the new calendar-portlet first.
        • Changing the times of the original event will change all other times except for the one instance chosen earlier to be an exception.
        • No new instances are created. (See screenshot).

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 38 weeks, 6 days ago

              Development

                Structure Helper Panel