PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-40167

Importing does not work: iCal file is reported empty even when it is not

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE RC2
    • Fix Version/s: 6.2.0 CE RC3
    • Component/s: Calendar
    • Labels:
      None
    • Fix Priority:
      5
    • Similar Issues:
      Show 5 results 

      Description

      Importing does not work: iCal file is reported empty even when it is not

      Steps to reproduce

      1. Get a valid iCal file (from iCal, Google Calendar or even from Liferay new calendar itself) with some events
      2. Go in "Calendars > Manage calendars"
      3. Click on the actions of one of the calendars.
      4. Go in "Import"
      5. Import the file

      Expected results

      • The events are imported in the calendar

      Actual results

      • No event is imported
      • A error message about an empty file is displayed.

        Issue Links

          Activity

          Sharon Choi added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0 + MySQL 5. Portal master GIT ID: 6f1870a35a769f84ac53671d818ae44b4f63509d.
          Plugins master GIT ID: a2f7de9ab2fc8c09f197b1a8729d6b479bc579ad.

          Importing iCal (ICS) files now import successfully without errors, and is no longer recorded as empty.


            People

            • Assignee:
              Sharon Choi
              Reporter:
              Adam Brandizzi
              Recent user:
              Randy Zhu
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 28 weeks, 1 day ago

                Development

                  Structure Helper Panel