Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.2.0 CE RC2
    • Fix Version/s: 6.2.0 CE RC2
    • Labels:
      None
    • Environment:
      Tomcat 7.0 + MySQL 5. Portal ee-6.2.x EE GIT ID: c8741816db0bcd15fd801af890fbeaef48820498.
      Plugins ee-6.2.x EE GIT ID: 65d1e08761de70f926edf703330b82a9ed6e93bd.
    • Fix Priority:
      4
    • Similar Issues:
      Show 4 results 

      Description

      Able to see other users when new filters are applied

      1. Edit the portlet.properties file of the chat portlet, located under WEB-INF/classes
         
        buddy.list.strategy=sites
        buddy.list.site.excludes=guest,management
        
      2. Log in as a portal admin.
      3. Add two sites: "Development" and "Management".
      4. Add three users: A, B and C. Make them all members of the default site "Liferay.com".
      5. Make User A, member of "Development" and B and C members of "Management".
      6. Deploy the chat portlet.
      7. Login as A, B and C in different browsers and check the buddy list in the chat portlet:

      Expected results:

      • A cannot see B and C
      • B and C cannot see A
      • B and C can see each other

      Actual results:

      • All users can see each other

        Activity

        Ginson Ren added a comment -

        Still can reproduce on:
        Tomcat 7.0 + MySQL 5. Portal master GIT ID: 5c2ebf7c4f9b5b1a2fbdf0c8b476cecb5b00ae2e.
        Plugins master GIT ID: 6bdd4d81b1fc9c4d8144922d26262629fe2b4217.

        Actual results:
        Everybody cannot see everybody else.

        Albert Lee added a comment -

        No Longer Reproducible through Manual Testing following the steps in the description.

        No Longer Reproducible on:
        Tomcat 7.0 + MySQL 5. Portal master GIT ID: c87383d2ad2938970df8ddb54322cc6d44b3cc5a.
        Plugins master GIT ID: 6bdd4d81b1fc9c4d8144922d26262629fe2b4217.

        After setting the portlet-ext.properties, none of the users can see each other in the chat portlet


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 31 weeks, 6 days ago

              Development

                Structure Helper Panel