Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-40297

Redirect to a site fails using My Sites when the virtual host is localhost

    Details

    • Type: Regression Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.2.0 CE RC2
    • Fix Version/s: 6.2.0 CE RC4
    • Labels:
    • Environment:
      Tomcat 7.0.40 + MySQL 5. Portal master GIT ID: 52c1c13e2b4b2c208b39a179ffef859c2655b326.
    • Fix Priority:
      3

      Description

      Steps to reproduce:

      1. Click My Sites > (Any site name)

      Expected results:
      It should redirect correctly to localhost

      Actual results:
      The redirect will be to http://:8080/web/guest/home and no pages display.

      Note:
      This also affects My Dashboard and My Profile. The workaround is to set the Virtual Host in Portal Instances or in Portal Settings to something else, and then setting it back to localhost. The redirect will work correctly after that.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kenji.heigel Kenji Heigel
              Reporter:
              kenji.heigel Kenji Heigel
              Participants of an Issue:
              Recent user:
              Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                7 years, 16 weeks, 4 days ago

                  Packages

                  Version Package
                  6.2.0 CE RC4