Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.2.0 CE RC2
    • Fix Version/s: 6.2.X EE
    • Labels:
    • Environment:
      Weblogic 11gR1 + SQL Server 2012. Portal 6.2.10 GIT ID: 03b8c10e438ce0f610a8ade7c43570b8bd6744d9
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Weblogic wont install xuggler

      1. Goto Control Panel > Server Administration > External Services
      2. Click install in Xuggler section at the bottom
      3. Click Save
      4. Restart server
      5. Goto Control Panel > Server Administration > External Services

      Expected result:
      An Enabled check box should appear

      Actual result:
      The Install button still there.
      It looks like Weblogic downloads to a temp file and never gets to ..\weblogic-10.3.6\domains\liferay\autodeploy\ROOT\WEB-INF\lib

      Works fine in tomcat

        Issue Links

          Activity

          Hide
          Igor Spasic added a comment - - edited

          Ive just tried this with Weblogic and everything seems fine.

          1) JAR is copied into the same place where all other portal jars are: eg:

          Oracle\Middleware11\user_projects\domains\liferay\servers\AdminServer\tmp\_WL_user\liferay-portal-6\qb88mq\war\WEB-INF\lib\
          

          2) Be sure to choose correct version - you cant use 64bit version (even if your OS is 64bit) if you are running 32bit JDK.

          3) Restart the server after the download.

          This worked on my side.

          Show
          Igor Spasic added a comment - - edited Ive just tried this with Weblogic and everything seems fine. 1) JAR is copied into the same place where all other portal jars are: eg: Oracle\Middleware11\user_projects\domains\liferay\servers\AdminServer\tmp\_WL_user\liferay-portal-6\qb88mq\war\WEB-INF\lib\ 2) Be sure to choose correct version - you cant use 64bit version (even if your OS is 64bit) if you are running 32bit JDK. 3) Restart the server after the download. This worked on my side.
          Hide
          Jane Kim (Inactive) added a comment -

          Reproduced on:
          Weblogic 10.3.6 + SQL Server 2012. Portal 6.2.x GIT ID: c8da79cfdc20e6932a0bc979d9c93fadb4947e30

          Show
          Jane Kim (Inactive) added a comment - Reproduced on: Weblogic 10.3.6 + SQL Server 2012. Portal 6.2.x GIT ID: c8da79cfdc20e6932a0bc979d9c93fadb4947e30
          Hide
          Igor Spasic added a comment -

          When you say: "reproduced" - what does it means? Would you be so kind to give some more details:

          • is the jar downloaded at location mentioned above, in my previous comment?
          • is it 32bit or 64bit os?
          • which version of xuggled did you downloaded?
          • did you restart the server?
          • what is the error message in the log? I've added a log so we can discover the error.

          Thank you!

          Show
          Igor Spasic added a comment - When you say: "reproduced" - what does it means? Would you be so kind to give some more details: is the jar downloaded at location mentioned above, in my previous comment? is it 32bit or 64bit os? which version of xuggled did you downloaded? did you restart the server? what is the error message in the log? I've added a log so we can discover the error. Thank you!
          Hide
          Jane Kim (Inactive) added a comment -

          The jar didn't download into the location. It seemed that Xuggler would not install at all.
          I used a 64 bit OS, installed the 64 bit, and yes I did restart the server.

          Show
          Jane Kim (Inactive) added a comment - The jar didn't download into the location. It seemed that Xuggler would not install at all. I used a 64 bit OS, installed the 64 bit, and yes I did restart the server.
          Hide
          Igor Spasic added a comment -

          Ok if jar has not been downloaded, that it would not work. Is there any exception?

          btw, it also may depend on which version of Java are you using? If you are using 32bit java, then you have to use 32bit version of xuggler, nevermind the OS.

          Can you manually download xuggler from the URL? Maybe it is just download problem?

          Finally, can you put the xuggler jar manually on destination and pretend as download worked? That would narrow the problem to the download.

          Thank you!

          Show
          Igor Spasic added a comment - Ok if jar has not been downloaded, that it would not work. Is there any exception? btw, it also may depend on which version of Java are you using? If you are using 32bit java, then you have to use 32bit version of xuggler, nevermind the OS. Can you manually download xuggler from the URL? Maybe it is just download problem? Finally, can you put the xuggler jar manually on destination and pretend as download worked? That would narrow the problem to the download. Thank you!
          Hide
          Joseph Chin added a comment -

          Hey Igor,

          It looks like, for me, that the jars are being copied and installed, but I am still not able to enable xuggler when I restart the app server. Is there any way that the SQL Server is the cause of the issue?

          Show
          Joseph Chin added a comment - Hey Igor, It looks like, for me, that the jars are being copied and installed, but I am still not able to enable xuggler when I restart the app server. Is there any way that the SQL Server is the cause of the issue?
          Hide
          Igor Spasic added a comment - - edited

          I have tested it again on latest trunk and it worked.

          Weblogic was started with 32bit JRockit. I have downloaded the 32bit xuggler jar from control panel and restarted the server. After the restart, portal says xuggler is installed and checkbox was working.

          SQL server should not be the cause, as this installation is not related to database.

          One more thing - in case of failure you should see an error message for xuggler on start. Can you paste it here?

          Show
          Igor Spasic added a comment - - edited I have tested it again on latest trunk and it worked. Weblogic was started with 32bit JRockit. I have downloaded the 32bit xuggler jar from control panel and restarted the server. After the restart, portal says xuggler is installed and checkbox was working. SQL server should not be the cause, as this installation is not related to database. One more thing - in case of failure you should see an error message for xuggler on start. Can you paste it here?
          Hide
          Igor Spasic added a comment -

          Im closing this issue as I never had any problems with this and I can not repeat the issue.

          Show
          Igor Spasic added a comment - Im closing this issue as I never had any problems with this and I can not repeat the issue.
          Hide
          Jane Kim (Inactive) added a comment -

          No Longer Reproducible through Manual Testing following the steps in the description.

          No Longer Reproducible on:
          Weblogic 11gR1 + SQL Server 2012. Portal 6.2.10 GIT ID: aa0392edfd5e57ae0280e986dbacc64da3c71412.

          Enabled checkbox is present.

          Show
          Jane Kim (Inactive) added a comment - No Longer Reproducible through Manual Testing following the steps in the description. No Longer Reproducible on: Weblogic 11gR1 + SQL Server 2012. Portal 6.2.10 GIT ID: aa0392edfd5e57ae0280e986dbacc64da3c71412. Enabled checkbox is present.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 5 weeks, 4 days ago

                Development

                  Structure Helper Panel